View Issue Details

IDProjectCategoryView StatusLast Update
0036982FPCDocumentationpublic2020-04-28 20:21
ReporterKai Burghardt Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSGNU/Linux 
Product Version3.0.4 
Summary0036982: spelling/style issues
DescriptionSince I’ve recently added a couple one-line issues 0036972 0036948 0036980 I’ve now reviewed some documentation using regular expressions:

• `[[:alnum:]][.:!][[:blank:]]+[[:lower:]]`: Start of sentence needs capital case. Surprisingly now I’ve found none.
• checked all occurrences `it's` if it’s meant to be a possessive

And I stumbled upon (and then deliberately searched for) a couple BE spellings. cf. 0035265
TagsNo tags attached.
Fixed in Revision1697
FPCOldBugId
FPCTarget-
Attached Files

Activities

Kai Burghardt

2020-04-28 15:00

reporter  

ide.tex.patch (1,916 bytes)   
--- ide.tex~	2020-04-28 12:46:47.493401127 +0000
+++ ide.tex	2020-04-28 13:00:19.349499856 +0000
@@ -1505,7 +1505,7 @@
 Replaced by the complete filename of the current configuration file.
 \item[\$DIR()]
 Replaced by the full directory of the filename argument, including the trailing
-directory separator. e.g.
+directory separator, e.g.
 \begin{verbatim}
   $DIR('d:\data\myfile.pas')
 \end{verbatim}
@@ -1833,7 +1833,7 @@
 %
 \subsection{Compiler options}
 The menu \menu{Options|Compiler} allow the setting of options that affect the
-compilers behaviour. When this menu item is chosen, a dialog pops up that
+compilers behavior. When this menu item is chosen, a dialog pops up that
 displays several tabs.
 
 There are six tabs:
@@ -2220,7 +2220,7 @@
 history lists, breakpoints etc.) will be saved.
 \end{description}
 \item[Options]
-Some special behaviours of the IDE can be specified here:
+Some special behaviors of the IDE can be specified here:
 \begin{description}
 \item[Auto track source]
 \item[Close on go to source] When checked, the messages window is closed
@@ -2312,7 +2312,7 @@
 the list of highlight extensions. On by default.
 \item[Block insert cursor]
 The insert cursor is a block instead of an underscore character. By default
-the overwrite cursor is a block. This option reverses that behaviour. Off by
+the overwrite cursor is a block. This option reverses that behavior. Off by
 default.
 \item[Vertical blocks]
 When selecting blocks spanning several lines, the selection doesn't 
@@ -2330,7 +2330,7 @@
 inserted at once. Off by default.
 \item[Keep trailing spaces]
 When saving a file, the spaces at the end of lines are stripped off. This
-option disables that behaviour; i.e. any trailing spaces are also saved
+option disables that behavior; i.e. any trailing spaces are also saved
 to file. Off by default.
 \item[Codecomplete enabled]
 Enable code completion. On by default.
ide.tex.patch (1,916 bytes)   
prog.tex.patch (3,563 bytes)   
--- prog.tex~	2020-04-28 12:43:06.190097413 +0000
+++ prog.tex	2020-04-28 12:50:42.584907862 +0000
@@ -136,7 +136,7 @@
 If they have a command line counterpart, the command line argument is
 restored as the default for each compiled file. The local directives
 influence the compiler's behavior from the moment they're encountered
-until the moment another switch annihilates their behaviour, or the end
+until the moment another switch annihilates their behavior, or the end
 of the current unit or program is reached.
 
 \subsection{\var{\protect\$A} or \var{\protect\$ALIGN} : Align Data}
@@ -210,7 +210,7 @@
 By default, the compiler uses shortcut boolean evaluation, i.e., the evaluation
 of a boolean expression is stopped once the result of the total
 expression is known with certainty. The \var{\{\$B \}} switch can be used
-to change this behaviour: if its argument is \var{+}, then the
+to change this behavior: if its argument is \var{+}, then the
 compiler will always evaluate all terms in the expression. If it is
 \var{-} (the default) then the compiler will only evaluate as many
 terms as are necessary to determine the result of the complete expression.
@@ -801,7 +801,7 @@
 When compiling using the \var{-Ci} compiler switch, the \fpc compiler inserts
 input/output checking code after every input/output call in the code.
 If an error occurred during input or output, then a run-time error will
-be generated. This switch can also be used to avoid this behaviour.
+be generated. This switch can also be used to avoid this behavior.
 
 If no I/O checking code is generated, to check if something went wrong, 
 the \var{IOResult} function can be used to see if everything went without 
@@ -1151,7 +1151,7 @@
 \item [N] where \var{N} is the maximum number of FPU registers to use.
 Currently this can be in the range 0 to 7.
 \item[Normal] restores the heuristic and standard behavior.
-\item[Default] restores the heuristic and standard behaviour.
+\item[Default] restores the heuristic and standard behavior.
 \end{description}
 
 \begin{remark}This directive is valid until the end of the current procedure.
@@ -1514,7 +1514,7 @@
 type.
 
 The \var{\{\$RANGECHECKS OFF\}} switch tells the compiler not to generate range checking
-code. This may result in faulty program behaviour, but no run-time errors
+code. This may result in faulty program behavior, but no run-time errors
 will be generated.
 
 \begin{remark}The standard functions \var{val} and \var{Read} will also check ranges
@@ -1575,7 +1575,7 @@
 scope. If the directive is set to \var{ON} then the values are inserted
 inside a scope with the name of the enumeration type.
 
-Practically this means that the following is the default behaviour:
+Practically this means that the following is the default behavior:
 \begin{verbatim}
 {$SCOPEDENUMS OFF}
 Type
@@ -2423,7 +2423,7 @@
 
 Under normal circumstances, the compiler itself will determine the values of
 the PE flags to write to the binary file, but this directive can be used to
-override the compiler's behaviour.
+override the compiler's behavior.
  
 \subsection{\var{\protect\$SMARTLINK} : Use smartlinking}
 
@@ -2498,7 +2498,7 @@
 of the locations where the files reside. If you are not sure, it is better
 practice to use makefiles and makefile variables.
 
-Note that this switch does not propagate to other units, i.e. it's scope
+Note that this switch does not propagate to other units, i.e. its scope
 is limited to the current unit.
 
 \subsection{\var{\protect\$VARPROPSETTER} : Enable use of var/out/constref
prog.tex.patch (3,563 bytes)   
ref.tex.patch (3,899 bytes)   
--- ref.tex~	2020-04-28 12:33:56.597952966 +0000
+++ ref.tex	2020-04-28 12:59:48.781044859 +0000
@@ -4047,7 +4047,7 @@
 an instance of an object that has an abstract method cannot be created
 directly.
 
-The reason is obvious: there is no method where the compiler could jump to !
+The reason is obvious: there is no method where the compiler could jump to!
 A method that is declared \var{abstract} does not have an implementation for
 this method. It is up to inherited objects to override and implement this
 method. Continuing our example, take a look at this:
@@ -5363,7 +5363,7 @@
 
 Although run-time type information is available for other types, these types cannot
 be used for a property or field definition in a published section. The
-information is present to describe f.e. arguments of procedures or functions.
+information is present to describe for example arguments of procedures or functions.
 
 \subsection{Storage information}
 The compiler offers two mechanisms to control whether a property is streamed
@@ -6094,7 +6094,7 @@
 
 \section{Reference counting}
 All COM interfaces use reference counting.  This means that whenever an
-interface is assigned to a variable, it's reference count is updated.
+interface is assigned to a variable, its reference count is updated.
 Whenever the variable goes out of scope, the reference count is
 automatically decreased. When the reference count reaches zero, usually the
 instance of the class that implements the interface, is freed.
@@ -7665,7 +7665,7 @@
 0
 \end{verbatim}
 The actual output will depend on the architecture, but the point is that \var{i} is no longer in scope,
-making the output of it's value meaningless, and  possibly even leading to access violations and program crashes.
+making the output of its value meaningless, and possibly even leading to access violations and program crashes.
 
 \section{Inheritance}
 As noted in the previous section, it is possible to create descendants of
@@ -8200,7 +8200,7 @@
 % Name scope
 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
 \section{Name scope and Identifiers}
-In Object Pascal, each identifier must be unique in it's namespace: the unit.
+In Object Pascal, each identifier must be unique in its namespace: the unit.
 In Objective-C, this need not be the case and each type identifier must be
 unique among its kind: classes, protocols, categories, fields or methods.
 This is shown in the definitions of the basic protocol and class of
@@ -8400,10 +8400,10 @@
   a  := e1 + f(2);
 \end{verbatim}
 
-A notable exception to this behaviour is the evaluation of boolean expressions: 
+A notable exception to this behavior is the evaluation of boolean expressions: 
 if short-circuit boolean evaluation is enabled (the default) then the
 compiler will evaluate from left to right, but will still respect
-precedence, i.e. in parts with equal precedence the left operand will always
+precedence, i.\,e. in parts with equal precedence the left operand will always
 be evaluated before the right one. Thus, the following example:
 \begin{verbatim}
   True or True and False
@@ -10768,7 +10768,7 @@
 \end{verbatim}
 
 Note that because an address is needed, no constant expressions can be
-passed to the function or procedure, i.e. given the above definition, 
+passed to the function or procedure, i.\,e. given the above definition, 
 the following will not work:
 \begin{verbatim}
  DoIt($0FFFFFF0);
@@ -12419,7 +12419,7 @@
 
 The implementation part is primarily intended for the implementation of the
 functions and procedures declared in the interface part. However, it can
-also contain declarations of it's own: the declarations inside the
+also contain declarations of its own: the declarations inside the
 implementation part are {\em not} accessible outside the unit.
 
 The initialization and finalization part of a unit are optional.
ref.tex.patch (3,899 bytes)   
user.tex.patch (775 bytes)   
--- user.tex~	2020-04-28 12:44:10.539058316 +0000
+++ user.tex	2020-04-28 13:00:03.109258133 +0000
@@ -250,7 +250,7 @@
 extensions with the text mode IDE.
 
 It is not recommended to install the compiler in a directory which
-has spaces in it's path name. Some of the external tools do not support
+has spaces in its path name. Some of the external tools do not support
 filenames with spaces in them, and you will have problems creating
 programs.
 
@@ -2699,7 +2699,7 @@
 
 
 \subsection{Options}
-\file{h2paspp} has a small number of options to control its behaviour:
+\file{h2paspp} has a small number of options to control its behavior:
 \begin{description}
 \item[-dsymbol] Define the symbol \var{symbol} before processing is started.
 \item[-h] Emit a small helptext.
user.tex.patch (775 bytes)   

Kai Burghardt

2020-04-28 15:06

reporter   ~0122497

Last edited: 2020-04-28 15:06

View 2 revisions

And “f.e.” is a rather rare abbreviation https://en.wiktionary.org/wiki/f.e. so I expanded it.

And appropriate thin (TeX) space between “i.e.” → “i.\,e.” cf. 0035574

Michael Van Canneyt

2020-04-28 20:21

administrator   ~0122510

Applied the patches, thank you very much !

Issue History

Date Modified Username Field Change
2020-04-28 15:00 Kai Burghardt New Issue
2020-04-28 15:00 Kai Burghardt Status new => assigned
2020-04-28 15:00 Kai Burghardt Assigned To => Michael Van Canneyt
2020-04-28 15:00 Kai Burghardt File Added: ide.tex.patch
2020-04-28 15:00 Kai Burghardt File Added: prog.tex.patch
2020-04-28 15:00 Kai Burghardt File Added: ref.tex.patch
2020-04-28 15:00 Kai Burghardt File Added: user.tex.patch
2020-04-28 15:06 Kai Burghardt Note Added: 0122497
2020-04-28 15:06 Kai Burghardt Note Edited: 0122497 View Revisions
2020-04-28 20:21 Michael Van Canneyt Status assigned => resolved
2020-04-28 20:21 Michael Van Canneyt Resolution open => fixed
2020-04-28 20:21 Michael Van Canneyt Fixed in Revision => 1697
2020-04-28 20:21 Michael Van Canneyt FPCTarget => -
2020-04-28 20:21 Michael Van Canneyt Note Added: 0122510