View Issue Details

IDProjectCategoryView StatusLast Update
0036988LazarusInstallerpublic2020-06-08 07:01
ReporterWoody Brison Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
OSwindows 
Summary0036988: installer needs a certificate jigger
DescriptionOK, it's time for me to learn Lazarus. I downloaded the installer. Looks like it's coming from SourcForge (safe?) Upon running the installer, Windows stops me and sez
"Windows protected your PC
"Microsoft Defender SmartScreen prevented an unrecognized app from starting. Running this app might put your PC at risk.
"App: "lazarus-2.0.8-fpc-3.0.4-win64.exe
"Publisher: Unknown publisher"
All this in the brightest red box imaginable.

Since I got this by following the link here on https://www.lazarus-ide.org/, I think it's probably safe, but why not get a working connectivity to all that's wise and right?
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0022580 new Installers are not codesigned 

Activities

Bart Broersma

2020-04-28 22:23

developer   ~0122513

Please move to Lazarus

Anton Kavalenka

2020-04-29 14:56

reporter   ~0122525

@Woody Brison
https://www.sslshopper.com/cheap-code-signing-certificates.html

I believe the Lazarus development community would thankfully accept the donation in amount 180-500 USD for buying code-signing certificate.

Marc Weustink

2020-04-30 08:32

administrator   ~0122536

It is not a one time donation, a certificate valid for windows mac and android would cost 500 USD each year

Trevor Roydhouse

2020-04-30 13:47

reporter   ~0122558

To be valid for code signing a macOS application, the certificate MUST be one provided by Apple through their Developer Program ($US 99 per year). Third party certificates do not work. I have no idea if an Apple certificate can be used for Windows and/or Android.

Martin Friebe

2020-06-06 20:32

manager   ~0123277

Duplicate issue

Issue History

Date Modified Username Field Change
2020-04-28 22:15 Woody Brison New Issue
2020-04-28 22:23 Bart Broersma Note Added: 0122513
2020-04-28 22:27 Jonas Maebe Project FPC => Lazarus
2020-04-29 14:56 Anton Kavalenka Note Added: 0122525
2020-04-30 08:32 Marc Weustink Note Added: 0122536
2020-04-30 13:47 Trevor Roydhouse Note Added: 0122558
2020-06-06 20:32 Martin Friebe Relationship added duplicate of 0022580
2020-06-06 20:32 Martin Friebe Assigned To => Martin Friebe
2020-06-06 20:32 Martin Friebe Status new => resolved
2020-06-06 20:32 Martin Friebe Resolution open => duplicate
2020-06-06 20:32 Martin Friebe LazTarget => -
2020-06-06 20:32 Martin Friebe Note Added: 0123277