View Issue Details

IDProjectCategoryView StatusLast Update
0037011FPCCompilerpublic2020-05-09 19:08
ReporterJulian Puhl Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformx64OSWindows 
Product Version3.3.1 
Summary0037011: Compiling Lazarus SVN with -O2 produces internal error 200405231
DescriptionI've had this issue for a while now and it still happens. If you compile Lazarus with e.g. the current revision 63113 you get the error message:

debugger.pp(5365,1) Error: Internal error 200405231
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0036775 new Internal Error 200405231 raised when manually compiling Lazarus 

Activities

noname012

2020-05-04 19:34

reporter   ~0122624

Duplicate of https://bugs.freepascal.org/view.php?id=36775
i36775new.patch (953 bytes)   
Index: compiler/nadd.pas
===================================================================
--- compiler/nadd.pas	(revision 45251)
+++ compiler/nadd.pas	(working copy)
@@ -1275,7 +1275,7 @@
                           { full boolean evaluation is only useful if the nodes are not too complex and if no flags/jumps must be converted,
                             further, we need to know the expectloc }
                           if (node_complexity(right)<=2) and
-                            not(left.expectloc in [LOC_JUMP,LOC_INVALID]) and not(right.expectloc in [LOC_JUMP,LOC_INVALID]) then
+                            not(left.expectloc in [LOC_FLAGS,LOC_JUMP,LOC_INVALID]) and not(right.expectloc in [LOC_FLAGS,LOC_JUMP,LOC_INVALID]) then
                             begin
                               { we need to copy the whole tree to force another pass_1 }
                               include(localswitches,cs_full_boolean_eval);
i36775new.patch (953 bytes)   

Issue History

Date Modified Username Field Change
2020-05-03 17:43 Julian Puhl New Issue
2020-05-04 19:34 noname012 Note Added: 0122624
2020-05-04 19:34 noname012 File Added: i36775new.patch
2020-05-09 19:08 Jonas Maebe Assigned To => Jonas Maebe
2020-05-09 19:08 Jonas Maebe Status new => resolved
2020-05-09 19:08 Jonas Maebe Resolution open => duplicate
2020-05-09 19:08 Jonas Maebe FPCTarget => -
2020-05-09 19:08 Jonas Maebe Relationship added duplicate of 0036775