View Issue Details

IDProjectCategoryView StatusLast Update
0037057LazarusIDEpublic2020-05-14 08:18
ReporterAwkward Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformx86OSWindows 
Summary0037057: Trunk startlazarus.exe can't find Lazarus executable
DescriptionLooks like it happens after #63114
when i compiling Lazarus from sources with make or fpcupdeluxe, i always get error when trying to use startlazarus.exe about "can't find lazarus"
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0037034 new FPC Startlazarus errors out on Lazarus executable not found. 

Activities

Awkward

2020-05-12 15:37

reporter  

sl.png (13,531 bytes)   
sl.png (13,531 bytes)   

Bart Broersma

2020-05-12 15:52

developer   ~0122730

Fixed typo in summary.

Juha Manninen

2020-05-12 20:59

developer   ~0122743

Last edited: 2020-05-12 21:08

View 2 revisions

> Looks like it happens after #63114

You mean revision 63114?
It is by Maxim 2020-05-04 :
 "SQLDB: moved all resource strings to sqldbstrconst.pas, merged translations accordingly"
It only affects resourcestrings in SQLDB. Certainly has no effect on StartLazarus.
Most likely this is a local configuration issue on your side.
BTW, why do you build Lazarus with fpcupdeluxe if you only want a native version (no cross-compilation or such)?

Awkward

2020-05-12 21:08

reporter   ~0122744

Last edited: 2020-05-12 21:16

View 2 revisions

Sorry, wrong about commit number.
don't know about local config - where to search?
Looks like it search "Lazarus" but not "lazarus.exe"

Juha Manninen

2020-05-12 22:12

developer   ~0122747

You can try with a clean local config.
If some recent commit really broke things, please find the actual revision.
 https://wiki.freepascal.org/How_do_I_create_a_bug_report#Regression_caused_by_a_certain_revision
Otherwise the forum or mailing list is a better place for asking questions.

Martin Friebe

2020-05-12 22:54

manager   ~0122749

Last edited: 2020-05-12 22:55

View 3 revisions

Please run cmd.exe (shell) and do

cd d:\SVN\LazSVN\
startlazarus.exe --debug-log=log.txt

Then provide the content of log.txt.

Do you have more than one Lazarus installed?

Awkward

2020-05-12 23:09

reporter   ~0122750

Last edited: 2020-05-12 23:11

View 2 revisions

content is
Adding "--debug-log=log.txt" as a parameter
Adding "" as a parameter

once i tried to make install with fpcupdeluxe to another dir , long time ago tried to install stable version - it wasn't happened.
if i rename lazarus.exe to lazarus (without ext), startlazarus trying to start, just like with clear, not configured environment

as i understands, fileutil.inc code don't work
function GetExeExt: string;
begin
  {$IFDEF WINDOWS}
  Result:='.exe';
  {$ELSE}
  Result:='';
  {$ENDIF}
end;

Martok

2020-05-13 01:43

reporter   ~0122752

It's a compiler issue. Duplicate of 0037034.

Juha Manninen

2020-05-13 07:38

developer   ~0122755

Resolving as duplicate. Please study the existing issues before creating a new one.

Alfred

2020-05-14 08:18

reporter   ~0122782

@Juha.
This is indeed a compiler bug.

However.

May I ask why use an inlined function and not a simple constant.
E.g. FPC uses a constant for the sharedlib extension.

Issue History

Date Modified Username Field Change
2020-05-12 15:37 Awkward New Issue
2020-05-12 15:37 Awkward File Added: sl.png
2020-05-12 15:52 Bart Broersma Summary Truck startlazarus.exe can't find Lazarus executable => Trunk startlazarus.exe can't find Lazarus executable
2020-05-12 15:52 Bart Broersma Description Updated View Revisions
2020-05-12 15:52 Bart Broersma LazTarget => -
2020-05-12 15:52 Bart Broersma Note Added: 0122730
2020-05-12 20:59 Juha Manninen Note Added: 0122743
2020-05-12 21:08 Juha Manninen Note Edited: 0122743 View Revisions
2020-05-12 21:08 Awkward Note Added: 0122744
2020-05-12 21:16 Awkward Note Edited: 0122744 View Revisions
2020-05-12 22:12 Juha Manninen Note Added: 0122747
2020-05-12 22:54 Martin Friebe Note Added: 0122749
2020-05-12 22:54 Martin Friebe Note Edited: 0122749 View Revisions
2020-05-12 22:55 Martin Friebe Note Edited: 0122749 View Revisions
2020-05-12 23:09 Awkward Note Added: 0122750
2020-05-12 23:11 Awkward Note Edited: 0122750 View Revisions
2020-05-13 01:43 Martok Note Added: 0122752
2020-05-13 07:32 Juha Manninen Relationship added duplicate of 0037034
2020-05-13 07:38 Juha Manninen Assigned To => Juha Manninen
2020-05-13 07:38 Juha Manninen Status new => resolved
2020-05-13 07:38 Juha Manninen Resolution open => duplicate
2020-05-13 07:38 Juha Manninen Note Added: 0122755
2020-05-14 08:18 Alfred Note Added: 0122782