View Issue Details

IDProjectCategoryView StatusLast Update
0037070LazarusIDEpublic2020-08-04 21:54
ReporterBenjamin Rosseaux Assigned ToMaxim Ganetsky  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.9 (SVN) 
Fixed in Version2.0.10 
Summary0037070: Lazarus 2.0.9 (63147) doesn't compile with FPC 3.3.1 (45361) due to IS operator precedence change, fix-patch attached
DescriptionLazarus 2.0.9 (63147) doesn't compile with FPC 3.3.1 (45361) due to IS operator precedence change

I've attached a patch for to fix it.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Benjamin Rosseaux

2020-05-14 07:05

reporter  

lazarus_2.0.9_for_fpc_3.3.1.patch (1,084 bytes)   
Index: components/ideintf/fieldseditor.pas
===================================================================
--- components/ideintf/fieldseditor.pas	(revision 63147)
+++ components/ideintf/fieldseditor.pas	(working copy)
@@ -439,7 +439,7 @@
     if i >= 0 then
       FieldsListBox.Items[i] := Field.FieldName;
   end else
-  if AComponent is TDataset And (AComponent = LinkDataset) then
+  if (AComponent is TDataset) And (AComponent = LinkDataset) then
     Caption := fesFeTitle + ' - ' + LinkDataset.Name;
 end;
 
Index: lcl/include/custompage.inc
===================================================================
--- lcl/include/custompage.inc	(revision 63147)
+++ lcl/include/custompage.inc	(working copy)
@@ -136,7 +136,7 @@
  ------------------------------------------------------------------------------}
 procedure TCustomPage.CMHitTest(var Message: TLMNCHITTEST);
 begin
-  if Parent is TCustomTabControl and
+  if (Parent is TCustomTabControl) and
      (TCustomTabControl(Parent).ActivePageComponent <> Self) then
     Message.Result := 0 // no hit
   else

Bart Broersma

2020-05-14 18:41

developer   ~0122797

Since this is fixed in trunk, probably a it was forgotten to merge it.
Can you find out in which revision it was solved in trunk?

Bart Broersma

2020-05-14 22:35

developer   ~0122810

OK: it was fixed in r62699 in trunk.
Unfortunately that revision also changes unrelated things that cannot be merged to fixes branch.

Maxim Ganetsky

2020-05-17 17:21

developer   ~0122884

Unrelated changes in this revision look harmless. I merged it.

Flávio Etrusco

2020-08-04 20:58

developer   ~0124563

AFAICS it is unnecessary to test "AComponent is TDataset" in
<code>
if (AComponent is TDataset) And (AComponent = LinkDataset) then
</code>
?

Juha Manninen

2020-08-04 21:54

developer   ~0124566

Flávio, true. I removed it in r63691. Thanks.

Issue History

Date Modified Username Field Change
2020-05-14 07:05 Benjamin Rosseaux New Issue
2020-05-14 07:05 Benjamin Rosseaux File Added: lazarus_2.0.9_for_fpc_3.3.1.patch
2020-05-14 18:41 Bart Broersma Note Added: 0122797
2020-05-14 22:35 Bart Broersma Note Added: 0122810
2020-05-17 17:21 Maxim Ganetsky Assigned To => Maxim Ganetsky
2020-05-17 17:21 Maxim Ganetsky Status new => resolved
2020-05-17 17:21 Maxim Ganetsky Resolution open => fixed
2020-05-17 17:21 Maxim Ganetsky Fixed in Version => 2.0.10
2020-05-17 17:21 Maxim Ganetsky LazTarget => -
2020-05-17 17:21 Maxim Ganetsky Note Added: 0122884
2020-08-04 20:58 Flávio Etrusco Note Added: 0124563
2020-08-04 21:54 Juha Manninen Note Added: 0124566