View Issue Details

IDProjectCategoryView StatusLast Update
0037083FPCDocumentationpublic2020-05-20 16:29
ReporterBi0T1N Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version3.3.1 
Summary0037083: Several options for make compiler/RTL not documented
Description- install to a custom directory: INSTALL_PREFIX
https://www.mail-archive.com/fpc-devel@lists.freepascal.org/msg31134.html

- significantly speed up the FPC source tree compilation: FPMAKEOPT="-T x" (with x = the number of cpu cores you have)
- reduce the number of times the compiler itself gets recompiled: NOWPOCYCLE=1
- probably options?: OPT="-gl -O-"
all from https://forum.lazarus.freepascal.org/index.php?topic=27645.0

- ?: LINKSMART=1
- ?: CREATESMART=1
- ?: DEBUG=1
- ?: OPTIMIZE=0
e.g. What is the difference between DEBUG/OPTIMIZE and OPT with -Ox and -g?
http://free-pascal-general.1045716.n5.nabble.com/Compiler-debug-build-td5729346.html

The problem is that all of them are not listed and explained on the wiki or on the following links (most important ones should be explained there):
https://www.freepascal.org/docs-html/current/prog/progse88.html#x329-345000F.3
https://www.freepascal.org/docs-html/current/prog/progsu220.html#x332-348000F.4.2
https://www.freepascal.org/docs-html/current/prog/progsu219.html#x331-347000F.4.1
TagsNo tags attached.
Fixed in Revision1706
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Michael Van Canneyt

2020-05-20 15:29

administrator   ~0122955

Added descriptions for most used options. Thanks for reporting!

Issue History

Date Modified Username Field Change
2020-05-15 20:18 Bi0T1N New Issue
2020-05-15 20:18 Bi0T1N Status new => assigned
2020-05-15 20:18 Bi0T1N Assigned To => Michael Van Canneyt
2020-05-20 15:29 Michael Van Canneyt Status assigned => resolved
2020-05-20 15:29 Michael Van Canneyt Resolution open => fixed
2020-05-20 15:29 Michael Van Canneyt Fixed in Version => 3.3.1
2020-05-20 15:29 Michael Van Canneyt Fixed in Revision => 1706
2020-05-20 15:29 Michael Van Canneyt FPCTarget => 3.2.0
2020-05-20 15:29 Michael Van Canneyt Note Added: 0122955
2020-05-20 16:29 Bi0T1N Status resolved => closed