View Issue Details

IDProjectCategoryView StatusLast Update
0037086PackagesPackagespublic2020-05-25 15:21
ReporterRolf Assigned ToMaxim Ganetsky  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.0.6 
Summary0037086: forgotten @ character in DropSource.pas line 921
Descriptionfunction DoDragDrop in ActiveX.pp needs the parameter pdwEffect:LPDWORD to call the WINOLE 'ole32.dll', but the variable DropEffect declared in line 867 (DropSource.pas) is a longint so the @ symbol is needed to give the address functionaly to the parameter
Steps To ReproduceI wrote a event handler assigned to the onmousemove event in a TDBgrid component and called DropFileSource.Execute in that procedure:

  if DragDetectPlus(TWinControl(Sender), Point(X, Y)) then
  begin
    DropFileSource1.Files.Clear;
    DropFileSource1.Files.Add(filename);
    DropFileSource1.Execute;
end;

I always get the exception External: SIGSEGV so I added the @ to the DropEffect variable in line 921 and voila: no more exception
Additional InformationThe issue is new since Lazarus 2.0.
In Lazarus 1.8.x everything was fine

The old DragDropLazarus package can't be added to Lazarus 2.0
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Juha Manninen

2020-05-17 16:00

developer   ~0122882

Create a patch against trunk sources please.

Bart Broersma

2020-05-17 21:44

developer   ~0122889

Last edited: 2020-05-17 21:45

View 3 revisions

DropSource.pas isn't part of Lazarus.
ActiveX is part of fpc.
So, what is this bugreport about?

delfion

2020-05-17 22:19

reporter   ~0122892

Last edited: 2020-05-17 22:21

View 2 revisions

DragDropLazarus.lpk package has DropSource.pas file.

Bart Broersma

2020-05-18 20:18

developer   ~0122910

DragDropLazarus.lpk package isn't part of official Lazarus.
So, where does it come from?
If it's not "ours", we're not responsible for bugs in that package, so this bugtracker isn't the correct place to file a bugreport.

I can only find a reference to it in the forum: https://forum.lazarus.freepascal.org/index.php?topic=38761.0

Maxim Ganetsky

2020-05-18 23:37

developer   ~0122916

As Bart correctly said, this package is not part of Lazarus. This should be reported to the package maintainers. Resolving.

Issue History

Date Modified Username Field Change
2020-05-16 15:36 Rolf New Issue
2020-05-17 16:00 Juha Manninen Note Added: 0122882
2020-05-17 21:44 Bart Broersma Status new => feedback
2020-05-17 21:44 Bart Broersma LazTarget => -
2020-05-17 21:44 Bart Broersma Note Added: 0122889
2020-05-17 21:44 Bart Broersma Note Edited: 0122889 View Revisions
2020-05-17 21:45 Bart Broersma Note Edited: 0122889 View Revisions
2020-05-17 22:19 delfion Note Added: 0122892
2020-05-17 22:21 delfion Note Edited: 0122892 View Revisions
2020-05-18 20:18 Bart Broersma Note Added: 0122910
2020-05-18 23:37 Maxim Ganetsky Assigned To => Maxim Ganetsky
2020-05-18 23:37 Maxim Ganetsky Status feedback => resolved
2020-05-18 23:37 Maxim Ganetsky Resolution open => no change required
2020-05-18 23:37 Maxim Ganetsky Widgetset Win32/Win64 => Win32/Win64
2020-05-18 23:37 Maxim Ganetsky Note Added: 0122916