View Issue Details

IDProjectCategoryView StatusLast Update
0037094FPCTextmode IDEpublic2020-05-17 20:36
ReporterKirinn Assigned ToMarco van de Voort  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.3.1 
Summary0037094: Entering any item in text mode IDE's help's index causes runtime error 213
DescriptionWith CHM help files set up as the text mode IDE wants, trying to use the Help Index causes a runtime error 213. The index itself does appear, listing all known help items, but attempting to select any of them produces a message box: "Program generated a RTE 213 at address $0000041E9FD. Save your sources and restart the IDE. [OK] [Cancel]".
Steps To Reproduce1. Acquire the CHM help files from the FTP: pub/fpc/beta/3.2.0-rc1/docs/doc-chm.zip
2. Unzip them somewhere convenient.
3. Open the textmode FP IDE.
4. Select Files... in the Help menu. Add your unzipped copy of toc.chm to the list, then the other CHM files.
5. Select Index in the Help menu.
6. Select any item in the Index list. Runtime error 213 occurs.
Additional InformationThis error happens for 3.2.0 RC1 tested on 64-bit Fedora 31 as well as 32-bit Windows 7, so it's a cross-platform bug.

It's kind of a pain to correctly set up the help files for the text mode IDE, but when I followed the same steps for the 3.0.4 IDE (using the 3.2.0 help files), the help index worked without crashing. So this is a regression in the 3.2.0 IDE specifically.
TagsNo tags attached.
Fixed in Revision45406,45407
FPCOldBugId
FPCTarget-
Attached Files

Activities

Marco van de Voort

2020-05-17 20:36

manager   ~0122886

FPC 3.2.x+ has complete rewritten CHM index handling, and fpdoc uses this now. This is for multilevel items in the index. (see also bug 0034206)

However this now means that a help index item (TCHMSitemapitem) now has subitems(TCHMSitemapsubitem). And the url is a different one than the old IDE looked. I now fixed that, and will make sure this comes in FPC 3.2.0 (retagging/repacking again, <groan>, this report came an hour after I just did that)

The fact that 3.0.4 worked is coincidental. Because it only has one local value per tchmsitemapitem, it just assigns them without taking care of proper pairings.

Issue History

Date Modified Username Field Change
2020-05-17 15:50 Kirinn New Issue
2020-05-17 20:36 Marco van de Voort Assigned To => Marco van de Voort
2020-05-17 20:36 Marco van de Voort Status new => resolved
2020-05-17 20:36 Marco van de Voort Resolution open => fixed
2020-05-17 20:36 Marco van de Voort Fixed in Revision => 45406,45407
2020-05-17 20:36 Marco van de Voort FPCTarget => -
2020-05-17 20:36 Marco van de Voort Note Added: 0122886