View Issue Details

IDProjectCategoryView StatusLast Update
0037146LazarusDocumentationpublic2020-08-11 16:09
ReporterDon Siders Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version2.1 (SVN) 
Summary0037146: Documentation updates
Description* Added file ttkern.xml (LazUtils)
* Added skeletons for missing topics in stdctrls.xml (LCL)

See attached files: ttkern.xml, stdctrls.xml.diff
TagsNo tags attached.
Fixed in Revisionr63278, r63717
LazTarget-
Widgetset
Attached Files

Activities

Don Siders

2020-05-27 01:21

reporter  

stdctrls.xml.diff (2,051 bytes)   
Index: docs/xml/lcl/stdctrls.xml
===================================================================
--- docs/xml/lcl/stdctrls.xml	(revision 63229)
+++ docs/xml/lcl/stdctrls.xml	(working copy)
@@ -695,6 +695,54 @@
       <element name="TComboBoxStyle.csOwnerDrawVariable">
         <short>The drop-down list elements are owner drawn and have an individual height.</short>
       </element>
+
+      <element name="TComboBoxStyleHelper">
+        <short>Helper for the TComboBoxStyle type</short>
+        <descr>
+          TComboBoxStyleHelper is a type helper for TComboBoxStyle.
+        </descr>
+        <seealso></seealso>
+      </element>
+
+      <element name="TComboBoxStyleHelper.HasEditBox">
+        <short></short>
+        <descr></descr>
+        <seealso></seealso>
+      </element>
+      <element name="TComboBoxStyleHelper.HasEditBox.Result">
+        <short></short>
+      </element>
+
+      <element name="TComboBoxStyleHelper.SetEditBox">
+        <short>Returns a style with/without edit box according to the current style</short>
+        <descr></descr>
+        <seealso></seealso>
+      </element>
+      <element name="TComboBoxStyleHelper.SetEditBox.Result">
+        <short></short>
+      </element>
+      <element name="TComboBoxStyleHelper.SetEditBox.AHasEditBox">
+        <short></short>
+      </element>
+
+      <element name="TComboBoxStyleHelper.IsOwnerDrawn">
+        <short></short>
+        <descr></descr>
+        <seealso></seealso>
+      </element>
+      <element name="TComboBoxStyleHelper.IsOwnerDrawn.Result">
+        <short></short>
+      </element>
+
+      <element name="TComboBoxStyleHelper.IsVariable">
+        <short></short>
+        <descr></descr>
+        <seealso></seealso>
+      </element>
+      <element name="TComboBoxStyleHelper.IsVariable.Result">
+        <short></short>
+      </element>
+
       <!-- alias type Visibility: default -->
       <element name="TOwnerDrawState" link="lcltype.TOwnerDrawState"/>
       <!-- procedure type Visibility: default -->
stdctrls.xml.diff (2,051 bytes)   
ttkern.xml (3,925 bytes)   
<?xml version="1.0" encoding="UTF-8"?>
<fpdoc-descriptions>
  <package name="lazutils">
    <!--
    ====================================================================
    TTKern
    ====================================================================
    -->
    <module name="TTKern">
      <short>Implements kerning tables used in the <file>LazFreeType.pas</file> unit</short>
      <descr/>

      <element name="Classes"/>
      <element name="SysUtils"/>
      <element name="EasyLazFreeType"/>
      <element name="TTTypes"/>
      <element name="TTFile"/>
      <element name="TTObjs"/>
      <element name="Fgl"/>

      <element name="TCustomKerningTable">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TCustomKerningTable.GetIsCrossStream"/>
      <element name="TCustomKerningTable.GetIsCrossStream.Result"/>
      <element name="TCustomKerningTable.GetIsHorizontal"/>
      <element name="TCustomKerningTable.GetIsHorizontal.Result"/>
      <element name="TCustomKerningTable.GetIsMinimum"/>
      <element name="TCustomKerningTable.GetIsMinimum.Result"/>
      <element name="TCustomKerningTable.GetIsOverride"/>
      <element name="TCustomKerningTable.GetIsOverride.Result"/>

      <element name="TCustomKerningTable.FCoverage">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TCustomKerningTable.Create">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TCustomKerningTable.Create.ACoverage">
        <short/>
      </element>

      <element name="TCustomKerningTable.LoadFromStream">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TCustomKerningTable.LoadFromStream.AStream">
        <short/>
      </element>
      <element name="TCustomKerningTable.LoadFromStream.ASize">
        <short/>
      </element>

      <element name="TCustomKerningTable.IsMinimum">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TCustomKerningTable.IsHorizontal">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TCustomKerningTable.IsCrossStream">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TCustomKerningTable.IsOverride">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TCustomKerningTable.GetKerning">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TCustomKerningTable.GetKerning.Result">
        <short/>
      </element>
      <element name="TCustomKerningTable.GetKerning.ALeftGlyph">
        <short/>
      </element>
      <element name="TCustomKerningTable.GetKerning.ARightGlyph">
        <short/>
      </element>
      <element name="TCustomKerningTable.GetKerning.AInfo">
        <short/>
      </element>

      <element name="TKerningTables">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TKerningTables.GetKerning">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TKerningTables.GetKerning.Result">
        <short/>
      </element>
      <element name="TKerningTables.GetKerning.ALeftGlyph">
        <short/>
      </element>
      <element name="TKerningTables.GetKerning.ARightGlyph">
        <short/>
      </element>

      <element name="LoadKerningTables">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="LoadKerningTables.AFace">
        <short/>
      </element>
      <element name="LoadKerningTables.AKerningTables">
        <short/>
      </element>

    </module>
    <!-- TTKern -->
  </package>
</fpdoc-descriptions>
ttkern.xml (3,925 bytes)   

Juha Manninen

2020-06-02 09:30

developer   ~0123187

I applied the LCL part in r63278.
I hold back the TTKern doc because I plan to move TrueType stuff into its own package. Hold on ...

Don Siders

2020-06-02 11:24

reporter   ~0123189

okay. Thanks for the info.

Juha Manninen

2020-08-11 11:41

developer   ~0124747

A new document folder for FreeType is created and ttkern.xml is added there.

Don Siders

2020-08-11 16:08

reporter   ~0124768

Not sure how this affects the docs build process. But well have similar issues with LazControls in the future. Closing this item.

Issue History

Date Modified Username Field Change
2020-05-27 01:21 Don Siders New Issue
2020-05-27 01:21 Don Siders File Added: stdctrls.xml.diff
2020-05-27 01:21 Don Siders File Added: ttkern.xml
2020-06-02 09:29 Juha Manninen Assigned To => Juha Manninen
2020-06-02 09:29 Juha Manninen Status new => assigned
2020-06-02 09:30 Juha Manninen Note Added: 0123187
2020-06-02 09:31 Juha Manninen Description Updated View Revisions
2020-06-02 09:31 Juha Manninen Fixed in Revision => r63278
2020-06-02 09:31 Juha Manninen LazTarget => -
2020-06-02 11:24 Don Siders Note Added: 0123189
2020-08-11 11:41 Juha Manninen Status assigned => resolved
2020-08-11 11:41 Juha Manninen Resolution open => fixed
2020-08-11 11:41 Juha Manninen Fixed in Revision r63278 => r63278, r63717
2020-08-11 11:41 Juha Manninen Note Added: 0124747
2020-08-11 16:08 Don Siders Note Added: 0124768
2020-08-11 16:09 Don Siders Status resolved => closed