View Issue Details

IDProjectCategoryView StatusLast Update
0037184LazarusIDEpublic2020-06-07 16:08
ReporterDon Siders Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWn64OSWindows  
Product Version2.1 (SVN) 
Fixed in Version2.2 
Summary0037184: IDE aborts when File > Close All is executed
DescriptionIDE aborts when File > Close All is executed. No error is displayed.

In the past , it always displayed the Project Open dialog and exited cleanly if no project was opened.
Steps To ReproduceCreate a new Application, and save to disk if you wish.
Run the File > Close All menu option.
IDE crashes/aborts with an error beep. No error message is displayed.
lazarus,exe may still be running in task manager, but not always.
TagsNo tags attached.
Fixed in Revision63322
LazTarget2.2
WidgetsetGTK
Attached Files

Activities

Juha Manninen

2020-06-07 08:33

developer   ~0123290

Last edited: 2020-06-07 10:56

View 4 revisions

OS = Windows, widgetset = GTK. I guess it should be GTK2.

[Edit] Actually I got an Access violation, too. Interesting!
---
Thread 1 "lazarus" received signal SIGSEGV, Segmentation fault.
0x0000000000cb406c in HIDEAUTOHINT (this=0x7fffa206a880) at sourceeditor.pp:2145
2145 if FManager.ActiveEditor.FCodeCompletionState.State in [ccsDot, ccsOnTyping] then
(gdb) bt
# 0 0x0000000000cb406c in HIDEAUTOHINT (this=0x7fffa206a880) at sourceeditor.pp:2145
# 1 0x0000000000ce4eba in ONUSERINPUT (this=0x7fffa01439f0, SENDER=0x7fff9ac451d0, MSG=512) at sourceeditor.pp:10991
# 2 0x00000000004a4419 in NOTIFYUSERINPUTHANDLER (this=0x7ffff7f8bfb0, SENDER=0x7fff9ac451d0, MSG=512) at include/application.inc:1548
# 3 0x0000000000487f53 in NOTIFYAPPLICATIONUSERINPUT (TARGET=0x7fff9ac451d0, MSG=512) at forms.pp:1919
# 4 0x00000000007c8540 in SLOTMOUSEMOVE (this=0x7fffa01d3810, SENDER=0x29db2b0, EVENT=0x7fffffffd530) at qt5/qtwidgets.pas:3851
# 5 0x00000000007c4f41 in EVENTFILTER (this=0x7fffa01d3810, SENDER=0x29db2b0, EVENT=0x7fffffffd530) at qt5/qtwidgets.pas:2629
# 6 0x00000000007f06c1 in EVENTFILTER (this=0x7fffa01d3810, SENDER=0x29db2b0, EVENT=0x7fffffffd530) at qt5/qtwidgets.pas:16896
# 7 0x00000000007f1f83 in VIEWPORTEVENTFILTER (this=0x7fffa01d3550, EVENT=0x7fffffffd530, RETVAL=0x7fffffffd097) at qt5/qtwidgets.pas:17405
# 8 0x00007ffff7e65e0d in QLCLAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQt5Pas.so.1
# 9 0x00007ffff6816feb in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
# 10 0x00007ffff743c641 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
# 11 0x00007ffff7441f27 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
# 12 0x00007ffff68172d2 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
# 13 0x00007ffff7440e0e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () from /usr/lib/libQt5Widgets.so.5
# 14 0x00007ffff7496bc6 in ?? () from /usr/lib/libQt5Widgets.so.5
# 15 0x00007ffff7499abf in ?? () from /usr/lib/libQt5Widgets.so.5
# 16 0x00007ffff743c652 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
# 17 0x00007ffff68172d2 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
# 18 0x00007ffff6d6153c in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () from /usr/lib/libQt5Gui.so.5
# 19 0x00007ffff6d3724c in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Gui.so.5
# 20 0x00007ffff2ce791c in ?? () from /usr/lib/libQt5XcbQpa.so.5
# 21 0x00007ffff546b43c in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
# 22 0x00007ffff54b8fa9 in ?? () from /usr/lib/libglib-2.0.so.0
# 23 0x00007ffff546a221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
# 24 0x00007ffff686e1ab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
# 25 0x0000000000697c37 in APPWAITMESSAGE (this=0x7ffff7f8c4d0) at qt5/qtobject.inc:309
# 26 0x00000000004a0091 in IDLE (this=0x7ffff7f8bfb0, WAIT=true) at include/application.inc:397
# 27 0x00000000004a2df5 in HANDLEMESSAGE (this=0x7ffff7f8bfb0) at include/application.inc:1209
# 28 0x00000000004a35bf in RUNLOOP (this=0x7ffff7f8bfb0) at include/application.inc:1327
# 29 0x0000000000697c13 in APPRUN (this=0x7ffff7f8c4d0, ALOOP=...) at qt5/qtobject.inc:288
# 30 0x00000000004a3533 in RUN (this=0x7ffff7f8bfb0) at include/application.inc:1315
# 31 0x0000000000425638 in main () at lazarus.pp:153

Do-wan Kim

2020-06-07 11:14

reporter   ~0123294

It may need nil checking.
37184_sourceeditor.pp.patch (646 bytes)   
Index: ide/sourceeditor.pp
===================================================================
--- ide/sourceeditor.pp	(revision 63321)
+++ ide/sourceeditor.pp	(working copy)
@@ -2142,7 +2142,7 @@
     FAutoHideHintTimer.Enabled := False;
   if AutoStartCompletionBoxTimer<>nil then
     AutoStartCompletionBoxTimer.Enabled:=false;
-  if FManager.ActiveEditor.FCodeCompletionState.State in [ccsDot, ccsOnTyping] then
+  if (FManager.ActiveEditor<>nil) and (FManager.ActiveEditor.FCodeCompletionState.State in [ccsDot, ccsOnTyping]) then
     FManager.ActiveEditor.FCodeCompletionState.State := ccsReady;
   if FAutoShown then
     HideHint;
37184_sourceeditor.pp.patch (646 bytes)   

Juha Manninen

2020-06-07 11:14

developer   ~0123295

Martin, this is caused by r63314.
 IDE, SourceEditor: implemented identifier-completion activates on typing. Issue 0033054 (different from patch)

Martin Friebe

2020-06-07 14:05

manager   ~0123304

Fixed, please close if ok

Don Siders

2020-06-07 16:08

reporter   ~0123305

No errors with revision 63322.

Thanks,

Issue History

Date Modified Username Field Change
2020-06-07 05:36 Don Siders New Issue
2020-06-07 08:33 Juha Manninen Note Added: 0123290
2020-06-07 10:53 Juha Manninen Note Edited: 0123290 View Revisions
2020-06-07 10:55 Juha Manninen Note Edited: 0123290 View Revisions
2020-06-07 10:56 Juha Manninen Note Edited: 0123290 View Revisions
2020-06-07 11:14 Juha Manninen Assigned To => Martin Friebe
2020-06-07 11:14 Juha Manninen Status new => assigned
2020-06-07 11:14 Do-wan Kim Note Added: 0123294
2020-06-07 11:14 Do-wan Kim File Added: 37184_sourceeditor.pp.patch
2020-06-07 11:14 Juha Manninen Note Added: 0123295
2020-06-07 14:05 Martin Friebe Status assigned => resolved
2020-06-07 14:05 Martin Friebe Resolution open => fixed
2020-06-07 14:05 Martin Friebe Fixed in Version => 2.2
2020-06-07 14:05 Martin Friebe Fixed in Revision => 63322
2020-06-07 14:05 Martin Friebe LazTarget => 2.2
2020-06-07 14:05 Martin Friebe Widgetset GTK => GTK
2020-06-07 14:05 Martin Friebe Note Added: 0123304
2020-06-07 16:08 Don Siders Note Added: 0123305
2020-06-07 16:08 Don Siders Status resolved => closed