View Issue Details

IDProjectCategoryView StatusLast Update
0037197FPCPackagespublic2020-06-10 10:05
ReporterAlfred Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0037197: OpenSSL failure on CentOS and alike.
DescriptionThe FPC package OpenSSL fails to load the needed libraries on CentOS.

CentOS 7:
1: does not have an libssl.so nor a basic numbered libssl.so.#
2: it does have libssl.so.10 and libssl.so.1.0.2k

I propose to add libssl.so.10 and libssl.so.11 as a search target.

Openssl.pas:
DLLVersions: array[1..19] of string = ('', '.1.1', '.11', '.10', '.1.0.6', '.1.0.5', '.1.0.4', '.1.0.3',
                                        '.1.0.2', '.1.0.1','.1.0.0','.0.9.8',
                                        '.0.9.7', '.0.9.6', '.0.9.5', '.0.9.4',
                                        '.0.9.3', '.0.9.2', '.0.9.1');
Additional InformationIf accepted, would be nice if implemented in fixes 3.2 also !
TagsNo tags attached.
Fixed in Revision45631
FPCOldBugId
FPCTarget4.0.0
Attached Files

Activities

Michael Van Canneyt

2020-06-10 10:05

administrator   ~0123365

merged to fixes_3_3, rev 45632.

But this will not be in 3.2, release process progressed to far.

Issue History

Date Modified Username Field Change
2020-06-10 09:34 Alfred New Issue
2020-06-10 09:52 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-06-10 09:52 Michael Van Canneyt Status new => assigned
2020-06-10 10:05 Michael Van Canneyt Status assigned => resolved
2020-06-10 10:05 Michael Van Canneyt Resolution open => fixed
2020-06-10 10:05 Michael Van Canneyt Fixed in Version => 3.3.1
2020-06-10 10:05 Michael Van Canneyt Fixed in Revision => 45631
2020-06-10 10:05 Michael Van Canneyt FPCTarget => 4.0.0
2020-06-10 10:05 Michael Van Canneyt Note Added: 0123365