View Issue Details

IDProjectCategoryView StatusLast Update
0037244LazarusIDEpublic2021-02-21 09:14
ReporterWill B Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformApple Mac miniOSmacOS 10.15.5 
Product Version2.0.8 
Summary0037244: Clicking 'Help' from Lazarus Help menu causes error and empty help viewer
DescriptionWhen clicking the Help menu item from the Lazarus Help menu, an error occurs. A help viewer appears, empty, then an error dialog says:

"lhelp
Invalid file handle.

Press OK to ignore and risk data corruption.
Press Abort to kill the program."
Steps To Reproduce* Have any project open in the IDE
* Click the 'Help' menu
* Choose the 'Help' menu item from the menu
* Empty help viewer and error dialog appear
TagsNo tags attached.
Fixed in Revisionr64306
LazTarget-
WidgetsetCocoa
Attached Files

Relationships

related to 0038276 resolvedJuha Manninen Patches Lazarus hanging when lHelp starts from Menu and by F1 pressing 

Activities

Will B

2020-06-24 07:55

reporter  

lazarus-help-issue.png (141,144 bytes)   
lazarus-help-issue.png (141,144 bytes)   

Dmitry Boyarintsev

2020-07-02 06:10

developer   ~0123712

that seems to be related to SimpleIPC

The error occurs on TSimpleIPCServer.PeekMessage() call

Andrey Sobol

2021-02-21 08:59

reporter   ~0129044

That fixed by the https://bugs.freepascal.org/view.php?id=38276

Juha Manninen

2021-02-21 09:14

developer   ~0129045

Ok, resolving.

Issue History

Date Modified Username Field Change
2020-06-24 07:55 Will B New Issue
2020-06-24 07:55 Will B File Added: lazarus-help-issue.png
2020-07-02 06:10 Dmitry Boyarintsev Note Added: 0123712
2021-02-21 08:59 Andrey Sobol Note Added: 0129044
2021-02-21 09:13 Juha Manninen Relationship added related to 0038276
2021-02-21 09:14 Juha Manninen Assigned To => Juha Manninen
2021-02-21 09:14 Juha Manninen Status new => resolved
2021-02-21 09:14 Juha Manninen Resolution open => fixed
2021-02-21 09:14 Juha Manninen Fixed in Revision => r64306
2021-02-21 09:14 Juha Manninen LazTarget => -
2021-02-21 09:14 Juha Manninen Widgetset Cocoa => Cocoa
2021-02-21 09:14 Juha Manninen Note Added: 0129045