View Issue Details

IDProjectCategoryView StatusLast Update
0037326LazarusLCLpublic2020-07-22 12:52
ReporterChris Rorden Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformMacBook 2012 Retina 13"OSDarwin 
Product Version2.1 (SVN) 
Summary0037326: Cocoa: TTrackbar does not relinquish focus
DescriptionThis Cocoa app starts with a trackball that has focus, illustrated by the tracker being shown in the highlight color. While one can select other components, the originally focused trackball never loses this highlight color.
Steps To ReproduceSee attached demo
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Chris Rorden

2020-07-10 21:32

reporter  

trackbar_focus.zip (130,880 bytes)

Dmitry Boyarintsev

2020-07-19 04:44

developer   ~0124165

this appears to be macOS native behavior
https://www.dropbox.com/s/o3pyvxwe7wk1ye7/trackfocus.mov?dl=0

not every control requests the focus on a click.
i.e. a trackbar doesn't require a focus, while edit does.

Will B

2020-07-20 06:24

reporter   ~0124181

To build on what Dmitry said, it looks like if you set TabStop to False for both trackbars, it will act more like macOS behaves with Xcode. In Xcode, I put two trackbars onto a form and ran it and I couldn't get either one of them to show the focus border, even by tabbing.

Issue History

Date Modified Username Field Change
2020-07-10 21:32 Chris Rorden New Issue
2020-07-10 21:32 Chris Rorden File Added: trackbar_focus.zip
2020-07-19 04:21 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2020-07-19 04:21 Dmitry Boyarintsev Status new => assigned
2020-07-19 04:44 Dmitry Boyarintsev Status assigned => resolved
2020-07-19 04:44 Dmitry Boyarintsev Resolution open => no change required
2020-07-19 04:44 Dmitry Boyarintsev LazTarget => -
2020-07-19 04:44 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2020-07-19 04:44 Dmitry Boyarintsev Note Added: 0124165
2020-07-20 06:24 Will B Note Added: 0124181
2020-07-22 12:52 Chris Rorden Status resolved => closed