View Issue Details

IDProjectCategoryView StatusLast Update
0037327FPCOtherpublic2020-07-11 14:57
ReporterPetru Simionescu Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version3.2.0 
Summary0037327: the "Free Pascal IDE" window has properties while the "Graph Window Application" does not
DescriptionThe "Free Pascal IDE" window has properties which can be stored and thus the size screen position can be the same at startup.
The "Graph Window Application" does not nave properties. Would it be possible to assign properties that can be edited and preserved for the Graph Window Application as well?

Thanks,

Petru
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Petru Simionescu

2020-07-11 04:36

reporter  

fpwindows.png (11,279 bytes)   
fpwindows.png (11,279 bytes)   

Sven Barth

2020-07-11 14:57

manager   ~0123888

This has nothing to do with FPC. The IDE window has these, because the Windows console host provides these. The Graph window is an ordinary Win32 window and the Pascal Graph API does not provide any interface for this, not to mention that it's simply intended for compatibility with the Turbo Pascal Graph unit. If you want explicit control for this use a full blown UI system like Lazarus LCL or MSEGUI or whatever.

Issue History

Date Modified Username Field Change
2020-07-11 04:36 Petru Simionescu New Issue
2020-07-11 04:36 Petru Simionescu File Added: fpwindows.png
2020-07-11 14:57 Sven Barth Assigned To => Sven Barth
2020-07-11 14:57 Sven Barth Status new => resolved
2020-07-11 14:57 Sven Barth Resolution open => won't fix
2020-07-11 14:57 Sven Barth FPCTarget => -
2020-07-11 14:57 Sven Barth Note Added: 0123888