View Issue Details

IDProjectCategoryView StatusLast Update
0037340LazarusWebsitepublic2020-07-27 03:25
ReporterTrevor Roydhouse Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionopen 
PlatformAppleOSmacOS 
Product Version2.0.10 
Summary0037340: [Sourceforge] Lazarus Mac OS X i386 / Lazarus 2.0.10 - no FPC 3.2.0 downloads
DescriptionOn the Sourceforge site, the macOS i386 download area for Lazarus 2.0.10 only contains FPC 3.0.4 downloads. The FPC 3.2.0 downloads are missing.

While the FPC 3.2.0 binary dmg from the macOS x86_64 file area works on macOS versions before 10.12, the FPC 3.2.0 source pkg in the macOS x86_64 file area does not (complains that it cannot be installed on the only disk in the system).
Tags2.0.10, file downloads
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Mattias Gaertner

2020-07-13 09:36

manager   ~0123954

I'm sorry, fpc 3.2.0 cannot be installed on my old Mac and my new Mac does not support 32bit.
So I have to resolve this issue as won't fix.
If you have a Mac in between, you have to build Lazarus yourself.

Trevor Roydhouse

2020-07-13 10:24

reporter   ~0123958

The issue is that the Sourceforge README for Lazarus 2.0.10 x86_64 file area tells people with a macOS version before 10.12 (I presume this is due to the pkgs refusing to install on versions before this), to download the files from the Lazarus 2.0.10 i386 file area - they obviously cannot do so because the files do not exist there.

At the moment, the x86_64 pkg in the fpc-3.2.0.intel-macosx.dmg DOES install on pre-10.12 versions, but the x86_64 fpc-src-3.2.0-2-laz.pkg does not. It is really only this pkg that is a problem. The i386 pkg in lazarus-2.0.10-i686-macosx.dmg does install.

So, I think it can be resolved by:

1) copying the x86_64 fpc-3.2.0.intel-macosx.dmg file to the Lazarus 2.0.10 i386 file area
2) copying the generic FPC Project Source distribution fpc-3.2.0.source.tar.gz to the i386 file area.

Sound reasonable?

Mattias Gaertner

2020-07-13 10:44

manager   ~0123959

The readme says: "For older Macs use the Mac OS i386 version"
I just checked: The Lazarus 2.0.10 for Mac i386 exists.

The fpc-3.2.0 requires at least 10.6. My old Mac is 10.4. It refuses to install.

The lazarus-2.0.10-i686-macosx.dmg is built with fpc 3.0.4. Installing fpc-3.2.0 is not sufficient.

Trevor Roydhouse

2020-07-13 14:59

reporter   ~0123982

I have just reinstalled Tiger over FreeBSD on my 2007 Mac mini.

Lazarus is listed as incompatible with Tiger - https://wiki.lazarus.freepascal.org/Installing_Lazarus_on_macOS#Compatibility

When I tried installing the fpc-3.2.0.intel-macosx.dmg (from x86_64) it said it required Leopard 10.5. Which is what I will update the Mac mini to tomorrow (it came with a Leopard DVD when I bought it).

The fact that it won't install on Tiger is not a big deal? It as been listed as incompatible for quite a while looking at the wiki history.

Trevor Roydhouse

2020-07-14 12:07

reporter   ~0124001

FPC 3.2.0 won't compile on less than 10.8 (needed because of the FPC CoreImage framework patch). However, the x86_64 FPC 3.2.0 binaries do install and compile my sample .pas files ok on 10.5, but Lazarus 2.0.10 cannot compile either Carbon or Cocoa interfaces using FPC 3.2.0, but does successfully compile the Carbon interface with FPC 3.0.4.

[I'd forgotten how slow a Core2Duo 1.83GHz CPU and spinning rust could be when installing OS X versions :-]

Mattias Gaertner

2020-07-14 12:50

manager   ~0124004

How did you install FPC 3.2.0 binaries on 10.5? The dmg refused to do so on my Mac.

What do you mean Laz 2.0.10 cannot compile Cocoa using FPC 3.2.0? People do that all the time. Do you mean on mac 10.5?

Jonas Maebe

2020-07-14 21:39

manager   ~0124016

> How did you install FPC 3.2.0 binaries on 10.5? The dmg refused to do so on my Mac.

Indeed. To solve the issue with the detection of the Xcode command line tools pre and post macOS 10.15, I had to change it from a "file exists" check into running a script. And a "flat installer package" only supports embedded scripts on Mac OS X 10.6 and later. I'll look into creating a package bundle instead. Since everything is on a disk image, that shouldn't matter (flat packages are mostly useful because you can download them directly as a single file).

> What do you mean Laz 2.0.10 cannot compile Cocoa using FPC 3.2.0? People do that all the time. Do you mean on mac 10.5?

On OS X 10.10 and earlier (not 10.8 and earlier), programs using the CocoaAll unit indeed won't link with FPC 3.2.0, because the CocoaAll unit now links to the CoreImage framework, which does not exist there. I've already fixed that in the fixes_3_2 branch, and I'm considering doing an FPC 3.2.0a release with just that change, because it's a major regression.

Trevor Roydhouse

2020-07-15 06:29

reporter   ~0124026

Q: How did you install FPC 3.2.0 binaries on 10.5? The dmg refused to do so on my Mac.

A: I used the pkg installer in the fpc-3.2.0.intel-macosx.dmg image downloaded from the Lazarus 2.0.10 x86_64 file area on Sourceforge. When tried this installer on Tiger 10.4 it complained that it needed at least Leopard 10.5. The Mac in question is a 2007 Mac mini: Core2Duo 1.83GHz, 4GB (3GB usable), 320GB HDD.

Q: What do you mean Laz 2.0.10 cannot compile Cocoa using FPC 3.2.0? People do that all the time. Do you mean on mac 10.5?

A: I cannot compile FPC 3.2.0 on Leopard 10.5 after patching to remove the CoreImage framework link from CocoaAll.pas. I can provide error details if needed in another bug report.

[My 2007 Mac mini -- 1.83GHz, 4GB (3GB usable), 320GB HDD -- has Leopard 10.5 installed on the HDD and both Snow Leopard 10.6 and Lion 10.7 installed on an external SSD for testing.]

Sven Barth

2020-07-15 15:24

manager   ~0124040

@Jonas Maebe: will you notify me when you've prepared the 3.2.0a so that I can rebuild PPC as well?

Trevor Roydhouse

2020-07-27 03:25

reporter   ~0124352

With Jonas' help (https://forum.lazarus.freepascal.org/index.php/topic,50515.15.html) I did manage to successfully compile FPC 3.2.0 on macOS 10.5. Full instructions https://wiki.freepascal.org/Installing_Lazarus_on_macOS#-_macOS_10.5_Leopard and then Lazarus (Carbon).

@Mattias - if you need (ssh) access to macOS 10.5 or indeed 10.6, 10,7 or 10.8 let me know.

Issue History

Date Modified Username Field Change
2020-07-13 09:22 Trevor Roydhouse New Issue
2020-07-13 09:25 Trevor Roydhouse Tag Attached: 2.0.10
2020-07-13 09:25 Trevor Roydhouse Tag Attached: file downloads
2020-07-13 09:36 Mattias Gaertner Assigned To => Mattias Gaertner
2020-07-13 09:36 Mattias Gaertner Status new => resolved
2020-07-13 09:36 Mattias Gaertner Resolution open => fixed
2020-07-13 09:36 Mattias Gaertner LazTarget => -
2020-07-13 09:36 Mattias Gaertner Note Added: 0123954
2020-07-13 10:24 Trevor Roydhouse Status resolved => assigned
2020-07-13 10:24 Trevor Roydhouse Resolution fixed => open
2020-07-13 10:24 Trevor Roydhouse Note Added: 0123958
2020-07-13 10:44 Mattias Gaertner Note Added: 0123959
2020-07-13 14:59 Trevor Roydhouse Note Added: 0123982
2020-07-14 12:07 Trevor Roydhouse Note Added: 0124001
2020-07-14 12:50 Mattias Gaertner Note Added: 0124004
2020-07-14 21:39 Jonas Maebe Note Added: 0124016
2020-07-15 06:29 Trevor Roydhouse Note Added: 0124026
2020-07-15 15:24 Sven Barth Note Added: 0124040
2020-07-27 03:25 Trevor Roydhouse Note Added: 0124352