View Issue Details

IDProjectCategoryView StatusLast Update
0037348LazarusDebuggerpublic2020-08-23 18:07
ReporterSergey Larin Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1 (SVN) 
Fixed in Version2.2 
Summary0037348: Internal Error 200405231 raised when compiling Lazarus with -O3
DescriptionWhen compiling the trunk version of Lazarus using the trunk version of FPC with the -O3 or -O4 option enabled, Internal error 200405231 occurs.
Target: Win64
Steps To Reproducemake OPT="-O3" distclean all install

debugger.pp(5365,1) Fatal: Internal error 200405231
Additional InformationThis issue contains a patch that is a workaround for error https://bugs.freepascal.org/view.php?id=36775
Tagspatch
Fixed in Revision63556
LazTarget2.2
Widgetset
Attached Files

Relationships

child of 0036775 resolvedSven Barth FPC Internal Error 200405231 raised when manually compiling Lazarus 

Activities

Sergey Larin

2020-07-14 12:44

reporter  

lazarus-internal-error-200405231-workaround.patch (426 bytes)   
diff --git a/debugger/debugger.pp b/debugger/debugger.pp
index 9f905f7367..d44d2f7154 100644
--- a/debugger/debugger.pp
+++ b/debugger/debugger.pp
@@ -5358,7 +5358,7 @@ begin
   while i >= 0 do
   begin
     Result := Items[i];
-    if (AnsiCompareText(Result.Name, GroupName) = 0) and (Ignore <> Result) then
+    if (Ignore <> Result) and (AnsiCompareText(Result.Name, GroupName) = 0) then
       Exit;
     Dec(i);
   end;

Sergey Larin

2020-07-14 12:56

reporter   ~0124005

Also, the proposed change is a minor optimization, since `Ignore <> Result` is much cheaper than `(AnsiCompareText(Result.Name, GroupName) = 0)`

Martin Friebe

2020-07-14 15:15

manager   ~0124009

Applied. Thanks.
Please test and close if ok.

Issue History

Date Modified Username Field Change
2020-07-14 12:44 Sergey Larin New Issue
2020-07-14 12:44 Sergey Larin Status new => assigned
2020-07-14 12:44 Sergey Larin Assigned To => Martin Friebe
2020-07-14 12:44 Sergey Larin File Added: lazarus-internal-error-200405231-workaround.patch
2020-07-14 12:45 Sergey Larin Tag Attached: patch
2020-07-14 12:56 Sergey Larin Note Added: 0124005
2020-07-14 15:15 Martin Friebe Status assigned => resolved
2020-07-14 15:15 Martin Friebe Resolution open => fixed
2020-07-14 15:15 Martin Friebe Fixed in Version => 2.2
2020-07-14 15:15 Martin Friebe Fixed in Revision => 63556
2020-07-14 15:15 Martin Friebe LazTarget => 2.2
2020-07-14 15:15 Martin Friebe Note Added: 0124009
2020-07-14 23:34 J. Gareth Moreton Relationship added child of 0036775
2020-08-23 18:07 Sergey Larin Status resolved => closed