View Issue Details

IDProjectCategoryView StatusLast Update
0037363FPCCompilerpublic2020-07-24 13:26
ReporterJens Assigned ToPierre Muller  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version3.2.0 
Summary0037363: fpc -iW shows 3.0.4 although compiled the 3.2.x branch
DescriptionWrong Version Numer displayed.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Jens

2020-07-15 17:04

reporter   ~0124050

... on Linux (debian derivate)

Pierre Muller

2020-07-15 17:13

developer   ~0124051

Hi,
  this is probably an installation problem:
try
fpc -PB
which will print the full path of the binary used to do all the work.
  Most probable is that fpc still find the old 3.0.4 version, because
you installed the new 3.2.1 snapshot without using
make installsymlink
in compiler directory.
  This is because the generated new compiler is installed
in a directory BASE/lib/fpc/3.2.1,
but this directory is not in the path, and the compiler is only found by fpc
in BASE/bin dir, if a symbolic link to BASE/lib/fpc/3.2.1/ppcCPUSUFFIX
is added.
  This is the role of "make installsymlink".
(Of course BASE and CPUSUFFIX need to be adapted to your setup)

  Please check and report if this solves your issue.


Jens

2020-07-15 17:33

reporter   ~0124052

Great and thanks! That was the cause!!!! Did not know about the make installsymlink, though make install would be enough. Always learning something new!!!

Pierre Muller

2020-07-15 17:39

developer   ~0124053

Good,
could you please close bug report?

Thanks in advance,

Pierre

Issue History

Date Modified Username Field Change
2020-07-15 17:02 Jens New Issue
2020-07-15 17:04 Jens Note Added: 0124050
2020-07-15 17:13 Pierre Muller Assigned To => Pierre Muller
2020-07-15 17:13 Pierre Muller Status new => feedback
2020-07-15 17:13 Pierre Muller FPCTarget => -
2020-07-15 17:13 Pierre Muller Note Added: 0124051
2020-07-15 17:33 Jens Note Added: 0124052
2020-07-15 17:33 Jens Status feedback => assigned
2020-07-15 17:39 Pierre Muller Status assigned => resolved
2020-07-15 17:39 Pierre Muller Resolution open => no change required
2020-07-15 17:39 Pierre Muller Note Added: 0124053
2020-07-24 13:26 Jens Status resolved => closed