View Issue Details

IDProjectCategoryView StatusLast Update
0037366LazarusLCLpublic2020-07-16 13:06
ReporterPaweł Dmitruk Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1 (SVN) 
Summary0037366: TSTringGrid - cannot change the cell being edited
DescriptionAfter rev 63541 cannot change the cell being edited when editor is active.

When commented line 8417 ( if Editor.Owner<>nil then // May be nil when the form is closing. ) in grids.pas - all it's ok
TagsNo tags attached.
Fixed in Revisionr63571
LazTarget-
Widgetset
Attached Files

Relationships

related to 0037202 resolvedJuha Manninen Packages TTidGrid crached on destroy 

Activities

Bart Broersma

2020-07-15 22:50

developer   ~0124067

Sample project?
Steps to reproduce?

Paweł Dmitruk

2020-07-16 08:00

reporter   ~0124073

Lazarus > Project > Project options > Version Info > try change few values
or
put StringGrid on Form > set Options.goEditing to True > run > try change few cells

Juha Manninen

2020-07-16 11:30

developer   ~0124081

Yes. It was caused by r63541. I should have tested for Editor.Parent instead of Editor.Owner. Fixed now.

Paweł Dmitruk

2020-07-16 13:06

reporter   ~0124089

Thank you, now it's ok.

Issue History

Date Modified Username Field Change
2020-07-15 22:46 Paweł Dmitruk New Issue
2020-07-15 22:50 Bart Broersma Note Added: 0124067
2020-07-15 22:51 Bart Broersma Assigned To => Juha Manninen
2020-07-15 22:51 Bart Broersma Status new => assigned
2020-07-16 08:00 Paweł Dmitruk Note Added: 0124073
2020-07-16 10:53 Juha Manninen Relationship added related to 0037202
2020-07-16 11:30 Juha Manninen Status assigned => resolved
2020-07-16 11:30 Juha Manninen Resolution open => fixed
2020-07-16 11:30 Juha Manninen Fixed in Revision => r63571
2020-07-16 11:30 Juha Manninen LazTarget => -
2020-07-16 11:30 Juha Manninen Note Added: 0124081
2020-07-16 13:06 Paweł Dmitruk Status resolved => closed
2020-07-16 13:06 Paweł Dmitruk Note Added: 0124089