View Issue Details

IDProjectCategoryView StatusLast Update
0037424pas2jstranspilerpublic2020-08-11 21:28
ReporterSimon Ameis Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Fixed in Versiontrunk 
Summary0037424: compileserver: add mime type text/css to LoadDefaultMimeTypes
DescriptionThe method THTTPCompilerApplication.LoadDefaultMimeTypes should also add text/css as this is a very common mime type for web applications.

<code>
  MimeTypes.AddType('text/css','css');
</code>

Additional InformationIf the mime type for CSS files can't be determined, they are sent as application/octet-stream. This is refused by Firefox. See https://stackoverflow.com/questions/48248832/stylesheet-not-loaded-because-of-mime-type for root case.
TagsNo tags attached.
Fixed in Revision46306
Attached Files

Activities

Michael Van Canneyt

2020-08-07 00:44

administrator   ~0124638

Added. Also let the server load the OS known extensions.
This is cross-platform now in 3.2 so it is always a good idea to do so.

Issue History

Date Modified Username Field Change
2020-07-27 19:50 Simon Ameis New Issue
2020-07-27 23:45 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-07-27 23:45 Michael Van Canneyt Status new => assigned
2020-08-07 00:44 Michael Van Canneyt Status assigned => resolved
2020-08-07 00:44 Michael Van Canneyt Resolution open => fixed
2020-08-07 00:44 Michael Van Canneyt Fixed in Version => trunk
2020-08-07 00:44 Michael Van Canneyt Fixed in Revision => 46306
2020-08-07 00:44 Michael Van Canneyt Note Added: 0124638
2020-08-11 21:28 Simon Ameis Status resolved => closed