View Issue Details

IDProjectCategoryView StatusLast Update
0037433LazarusIDEpublic2020-08-16 17:50
ReporterBirger Sørensen Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.10 
Fixed in Version2.2 
Summary0037433: Markings are removed, when they are used.
DescriptionWhen a text is marked, and it is dragged with the mouse the Text can be moved or copied(Ctrl held down) to a new location. But the marking is removed, when mousebutton is released. So if you need to copy the same text to more than one location, it can not be done with the mouse, without repeating the marking first. The copied (or moved) text should remain marked.
TagsNo tags attached.
Fixed in Revision63757
LazTarget2.2
WidgetsetWin32/Win64
Attached Files

Activities

Martin Friebe

2020-08-16 17:50

manager   ~0124927

r63757
Please test and close if ok.

The newly dropped text will become selected.

Except, if you have as existing "persistent selection" then the old selection will be preferred).
That means:
- In a drag-move (not copy) within the same editor, the old selection no longer exists (since the text is removed), so in this case the new text is selected too.
- In a drag-copy, of a persistent selection (within the same editor) will keep the old text selected.
- Dragging from a different editor, will keep a persistent selection if it exists, and otherwise select the inserted text.

For none-persistent selections it is only possible to select the new inserted text.
The selection can not be kept at the source-position, because none persistence selections are supposed to be cleared if the caret moves away from them. And the caret goes to the new text.
(Exception: This selection-clearing is prevented while dragging, when the caret indicates the drop location)

Issue History

Date Modified Username Field Change
2020-07-28 18:53 Birger Sørensen New Issue
2020-07-28 21:52 Martin Friebe Assigned To => Martin Friebe
2020-07-28 21:52 Martin Friebe Status new => assigned
2020-08-16 17:50 Martin Friebe Status assigned => resolved
2020-08-16 17:50 Martin Friebe Resolution open => fixed
2020-08-16 17:50 Martin Friebe Fixed in Version => 2.2
2020-08-16 17:50 Martin Friebe Fixed in Revision => 63757
2020-08-16 17:50 Martin Friebe LazTarget => 2.2
2020-08-16 17:50 Martin Friebe Widgetset Win32/Win64 => Win32/Win64
2020-08-16 17:50 Martin Friebe Note Added: 0124927