View Issue Details

IDProjectCategoryView StatusLast Update
0037452LazarusLCLpublic2020-08-05 15:42
ReporterReinhard Berger Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
OSLinux 
Product Version2.1 (SVN) 
Summary0037452: SigSev Exception when closing MDI Style forms
DescriptionI don't know if this is a bug or not, but since it only appears on all Qt widgetsets and not on GTK2 i'll post it.

Whenever a form calls a 2nd form with the property "fsMDIForm" set under "FormSytle" and i close this form, an exception will appear in
unit "qtwidgets"

function TQtWidget.GetWidget: QWidgetH;
begin
  Result := QWidgetH(TheObject);
end;
       
Steps To ReproduceCreate Form1
Create Form2
set FormSytle from "fsNormal" to "fsMDIForm"
call
"Form2.showmodal"
Close Form2
Exception will appear.
Additional Informationworks without exception under GTK2.
Note : I don't need that style set, it was just a mistake but wondered why it works under GTK2 and not under Qt4/Qt5
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetQT, QT5
Attached Files

Activities

Reinhard Berger

2020-07-30 19:38

reporter  

Screenshot-qt-mdi.png (209,230 bytes)   
Screenshot-qt-mdi.png (209,230 bytes)   

Zeljan Rikalo

2020-08-05 10:17

developer   ~0124576

1.Please attach example project.
2.MDI is not implemented under gtk2/gtk3

Reinhard Berger

2020-08-05 12:50

reporter   ~0124578

Added sample
Qt-MDI.zip (109,327 bytes)

Zeljan Rikalo

2020-08-05 14:05

developer   ~0124579

This is wrong usage of MDI. You should set Form1 to fsMDIForm and Form2 to fsMDIChild. Also mdi children cannot be shown modal.
Such code will crash on any mdi implemented widgetset.

Reinhard Berger

2020-08-05 14:18

reporter   ~0124580

That was not intended.

The purpose was not to create a MDI form.

Somehow i have set this style on the form, and always used gtk2 as toolkit where this exception does not appear.

Just as i switched to qt this exception appeared , and i didn't know why until i found out that the reason was setting the wrong value to "FormStyle"

Maybe a warning message in the messagelog during compiling would be a good reason to prevent this.

Zeljan Rikalo

2020-08-05 15:42

developer   ~0124581

Resolved as "no change required", so pls close.

Issue History

Date Modified Username Field Change
2020-07-30 19:38 Reinhard Berger New Issue
2020-07-30 19:38 Reinhard Berger File Added: Screenshot-qt-mdi.png
2020-08-05 10:16 Zeljan Rikalo Assigned To => Zeljan Rikalo
2020-08-05 10:16 Zeljan Rikalo Status new => assigned
2020-08-05 10:17 Zeljan Rikalo Status assigned => feedback
2020-08-05 10:17 Zeljan Rikalo LazTarget => -
2020-08-05 10:17 Zeljan Rikalo Note Added: 0124576
2020-08-05 12:50 Reinhard Berger Note Added: 0124578
2020-08-05 12:50 Reinhard Berger File Added: Qt-MDI.zip
2020-08-05 12:50 Reinhard Berger Status feedback => assigned
2020-08-05 14:05 Zeljan Rikalo Note Added: 0124579
2020-08-05 14:18 Reinhard Berger Note Added: 0124580
2020-08-05 15:42 Zeljan Rikalo Status assigned => resolved
2020-08-05 15:42 Zeljan Rikalo Resolution open => no change required
2020-08-05 15:42 Zeljan Rikalo Widgetset QT, QT5 => QT, QT5
2020-08-05 15:42 Zeljan Rikalo Note Added: 0124581