View Issue Details

IDProjectCategoryView StatusLast Update
0037484LazarusInstallerpublic2020-08-05 20:40
ReporterBBaz Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
OSWindows 
Product Version2.0.10 
Summary0037484: automated installation does not work on windows
Descriptionthere's no way to do an automated installation of Lazarus. In theory inno setup should allow that [1] but in this particular case there's a problem. I report this because I try to build dexed on Appveyor [2], as it is done on gitlab CI for the linux version.

[1]: https://jrsoftware.org/ishelp/index.php?topic=setupcmdline
[2]: https://ci.appveyor.com/project/BBasile/dexed/builds/34473897
Steps To Reproduceverify that laz is not setup then in a PS shell:

---
$ (new-object net.webclient).DownloadFile('https://github.com/NilsLankila/laz-bin-cache/releases/download/v2.0.10/lazarus-2.0.10-fpc-3.2.0-win64.exe', 'C:\laz_setup.exe')
$ C:\laz_setup.exe /VERYSILENT /SUPPRESSMSGBOXES /DIR="C:\lazarus" /SP- /LOG=C:\artifacts\laz_setup.txt
---

and you can see that C:\Lazarus\bin\lazbuild.exe is not there.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

BBaz

2020-08-04 16:51

reporter   ~0124552

You can remove the "/LOG=C:\artifacts\laz_setup.txt" from the command line when testing.
That was a failed attempt to make install log available as a build artifact in order to find the location of lazbuild.

Martin Friebe

2020-08-04 20:32

manager   ~0124562

>>> C:\Lazarus\bin\lazbuild.exe

There is on "bin" folder in Lazarus (on Windows).
Lazbuild is in C:\lazarus.

I tested with lazarus-2.0.10-fpc-3.2.0-win32.exe
under powershell and cmd.exe. Both installed lazbuild.

BBaz

2020-08-04 21:33

reporter   ~0124564

That doesn't work on Appveyor. I dont know why. I've added a simple Get-Item on C:\Lazarus which fails because the thing does not exist. Also the installation process taking 2 seconds is an indication. That should take at least 1 minute.

https://ci.appveyor.com/project/BBasile/dexed/builds/34479648#L44

Martin Friebe

2020-08-04 22:00

manager   ~0124567

The installation runs in the background. (No idea why). The installer immediately returns to the console, but then keeps running and installing.

If you know an option to change that, it can probably be added.

Martin Friebe

2020-08-04 22:09

manager   ~0124568

The following batch (need adjust folders) should allow to build an empty installer (very quick). In case you want to run tests.

rem any empty dir -> installer will be copied to this
SET LAZBUILD_TARGET_DIR=B:\Installers\

SET OLDCURDIR=%CD%
SET OLDCURDRIVE=%CD:~,2%

rem insinde SVN for Lazarus
set WORKDIR=B:\Installers\build_sources\svn_laz\tools\install\win\
cd %WORKDIR%

rem inno path
SET ISCC="C:\Program Files (x86)\Inno Setup 5.6.0U\iscc.exe"

rem any empty dir
SET BUILDDIR=b:\tmp_lazbuild
SET OutputFileName=lazarus-DUMMY

rmdir /s /q %BUILDDIR%
mkdir %BUILDDIR%
mkdir %BUILDDIR%\fpc\bin
echo 1 >%BUILDDIR%\test.txt
rem make sure the installer has an fpcmkcfg.....
copy B:\Installers\build_sources\fpc_build_tag\install\binw32\gecho.exe %BUILDDIR%\fpc\bin\fpcmkcfg.exe

%ISCC% lazarus.iss >> installer.log

%OLDCURDRIVE%
cd %OLDCURDIR%

move %WORKDIR%\installer.log %OLDCURDIR%
move %WORKDIR%\svninfo.txt %OLDCURDIR%
move %WORKDIR%\Output\*.* %OLDCURDIR%

pause

BBaz

2020-08-05 08:01

reporter   ~0124574

Thanks Martin for pointing out the problem. You can close,


$ Start-Process -FilePath "C:\laz_setup.exe" -Wait -ArgumentList "/SILENT", "/SUPPRESSMSGBOXES", "/DIR=C:\lazarus"

works.

Issue History

Date Modified Username Field Change
2020-08-04 16:44 BBaz New Issue
2020-08-04 16:51 BBaz Note Added: 0124552
2020-08-04 20:32 Martin Friebe Assigned To => Martin Friebe
2020-08-04 20:32 Martin Friebe Status new => feedback
2020-08-04 20:32 Martin Friebe LazTarget => -
2020-08-04 20:32 Martin Friebe Note Added: 0124562
2020-08-04 21:33 BBaz Note Added: 0124564
2020-08-04 21:33 BBaz Status feedback => assigned
2020-08-04 22:00 Martin Friebe Note Added: 0124567
2020-08-04 22:09 Martin Friebe Note Added: 0124568
2020-08-05 08:01 BBaz Note Added: 0124574
2020-08-05 18:53 Martin Friebe Status assigned => resolved
2020-08-05 18:53 Martin Friebe Resolution open => no change required
2020-08-05 20:40 BBaz Status resolved => closed