View Issue Details

IDProjectCategoryView StatusLast Update
0037496FPCCompilerpublic2020-08-08 21:56
Reporterdoj Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformi386OSWindows 
Product Version3.2.0 
Summary0037496: Incorrect "Undefined symbol" for unit's private function with public inlined overloaded versions
DescriptionSee attachment. FPC 3.2.0 fails compilation with the following error:

Error: Undefined symbol: DPARSER_$$_PARSEHEXU32UNSAFE$PCHAR$PCHAR$LONGWORD$$LONGWORD

If I remove inline modifier, it compiles. The same source works fine with fpc 3.0.2.
Steps To ReproduceCommand I use for building the example:

fpc -Sd -Oodfa -Sew -Xm -vm5037 -g -gl -al -an -ar -at -vq -Sa main.pas -omain.exe
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0037423 resolvedJonas Maebe inline bug 

Activities

doj

2020-08-06 07:29

reporter  

undefined_symbol.zip (1,368 bytes)

Issue History

Date Modified Username Field Change
2020-08-06 07:29 doj New Issue
2020-08-06 07:29 doj File Added: undefined_symbol.zip
2020-08-08 21:56 Jonas Maebe Assigned To => Jonas Maebe
2020-08-08 21:56 Jonas Maebe Status new => resolved
2020-08-08 21:56 Jonas Maebe Resolution open => duplicate
2020-08-08 21:56 Jonas Maebe FPCTarget => -
2020-08-08 21:56 Jonas Maebe Relationship added duplicate of 0037423