View Issue Details

IDProjectCategoryView StatusLast Update
0037497LazarusWidgetsetpublic2020-09-05 10:13
ReporterCudaText man_ Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version2.1 (SVN) 
Summary0037497: Cocoa: need support for OS-added "Emoji" menu item
DescriptionCudaText has auto-added Emoji menu item (AFAIK in Edit menu) which shows OS dialog to choose emojis, but CudaText don't get this emojis into its editor. So how to make emojis go to CudaText editor (it is ATSynEdit component)?
Need some tips or helper procedure which CudaText can call.
TagsNo tags attached.
Fixed in Revision63703 63710 63711
LazTarget-
WidgetsetCocoa
Attached Files

Activities

CudaText man_

2020-08-06 08:02

reporter   ~0124600

macos.png (211,300 bytes)   
macos.png (211,300 bytes)   

Dmitry Boyarintsev

2020-08-09 06:36

developer   ~0124683

Last edited: 2020-08-11 21:06

View 2 revisions

for each emoji or symbol selected (in case there's a possibility to enter multiple) you should be getting UTF8KeyPress event.
UTF8Char - should represent a single emoji symbol. (UTF8 doesn't have surrogate pairs, as it represents a single unicode point by itself)


please test and close if ok.

wp

2020-08-09 15:29

developer   ~0124695

Last edited: 2020-08-09 15:29

View 2 revisions

I cannot compile Laz/cocoa any more, after the change in r63703

Dmitry Boyarintsev

2020-08-10 00:41

developer   ~0124707

@wp, is it true that you're using FPC an earlier version than 3.2.0?

wp

2020-08-10 01:03

developer   ~0124708

Normally I use 3.2.0, but yes, my VM with macOS has only 3.0.4. But wasn't it intended that Laz should compile at least with the current and previous FPC release, i.e. with 3.2.0 and 3.0.4?

Dmitry Boyarintsev

2020-08-10 01:23

developer   ~0124709

making it compile for 3.0.4 should not be a problem

wp

2020-08-10 11:18

developer   ~0124717

Thank you. Now I am able to compile the IDE again.

CudaText man_

2020-08-11 18:01

reporter   ~0124772

Last edited: 2020-08-11 19:02

View 2 revisions

GOOD. it works even in IDE in macOS 10.8.

CudaText man_

2020-08-11 19:02

reporter   ~0124775

And it works in CudaText!!

Issue History

Date Modified Username Field Change
2020-08-06 07:56 CudaText man_ New Issue
2020-08-06 08:02 CudaText man_ Note Added: 0124600
2020-08-06 08:02 CudaText man_ File Added: macos.png
2020-08-09 06:36 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2020-08-09 06:36 Dmitry Boyarintsev Status new => resolved
2020-08-09 06:36 Dmitry Boyarintsev Resolution open => fixed
2020-08-09 06:36 Dmitry Boyarintsev Fixed in Revision => 63703
2020-08-09 06:36 Dmitry Boyarintsev LazTarget => -
2020-08-09 06:36 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2020-08-09 06:36 Dmitry Boyarintsev Note Added: 0124683
2020-08-09 15:29 wp Status resolved => assigned
2020-08-09 15:29 wp Resolution fixed => open
2020-08-09 15:29 wp Note Added: 0124695
2020-08-09 15:29 wp Status assigned => feedback
2020-08-09 15:29 wp Note Edited: 0124695 View Revisions
2020-08-10 00:41 Dmitry Boyarintsev Note Added: 0124707
2020-08-10 01:03 wp Note Added: 0124708
2020-08-10 01:23 Dmitry Boyarintsev Note Added: 0124709
2020-08-10 03:41 Dmitry Boyarintsev Status feedback => resolved
2020-08-10 03:41 Dmitry Boyarintsev Resolution open => fixed
2020-08-10 03:41 Dmitry Boyarintsev Fixed in Revision 63703 => 63703 63710 63711
2020-08-10 03:41 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2020-08-10 11:18 wp Note Added: 0124717
2020-08-11 18:01 CudaText man_ Note Added: 0124772
2020-08-11 19:02 CudaText man_ Note Added: 0124775
2020-08-11 19:02 CudaText man_ Note Edited: 0124772 View Revisions
2020-08-11 21:06 Dmitry Boyarintsev Note Edited: 0124683 View Revisions
2020-09-05 10:13 CudaText man_ Status resolved => closed