View Issue Details

IDProjectCategoryView StatusLast Update
0037498FPCPackagespublic2020-12-29 18:07
ReporterCudaText man_ Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionwon't fix 
Product Version3.3.1 
Summary0037498: TRegExpr in upstream now has more features
Description- Named groups and named back references
- Positive look ahead
- Positive look behind

You will find code in official repo https://github.com/andgineer/TRegExpr
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

CudaText man_

2020-09-14 15:12

reporter   ~0125539

Last edited: 2020-09-14 15:13

View 2 revisions

Update

- More patches were added. Upstream now has all 4 kinds of lookaround!
- I won't make diff against SVN as it's HUGE, you need to recreate entire file from upstream, sorry
- when you will do it, pls DROP this nasty property to show error for empty InputStr

Bi0T1N

2020-11-25 16:04

reporter   ~0127176

Last edited: 2020-11-25 16:06

View 3 revisions

Might be a good idea to replace the FPC version with the recent version from upstream as it offers several new features.
Additionally the provided version in FPC 3.2 is broken and doesn't find the correct matches, see https://forum.lazarus.freepascal.org/index.php/topic,52275.0.html (probably 0037048?)

CudaText man_

2020-12-28 12:12

reporter   ~0127852

Pls update the TRegExpr?

Sven Barth

2020-12-29 16:55

manager   ~0127899

Please provide patches. We won't pick around "upstream" and we certainly won't simply replace ours.

Michael Van Canneyt

2020-12-29 17:18

administrator   ~0127906

If you want to have the TRegexpr updates, please provide a patch.
A patch is really necessary because we need to retain backwards compatibility.
That also means we do not drop properties.

The upstream maintainer may not care about that, but we do.

Sven already commented on it, I have asked for it multple times (see many related bugreports), always to no use.

If you want to have an updated TRegexpr in FPC, open a new bugreport with a patch attached.
If you don't want to provide patches: sorry, then simply use the upstream TRegexpr.

Issue History

Date Modified Username Field Change
2020-08-06 10:14 CudaText man_ New Issue
2020-09-14 15:12 CudaText man_ Note Added: 0125539
2020-09-14 15:13 CudaText man_ Note Edited: 0125539 View Revisions
2020-11-25 16:04 Bi0T1N Note Added: 0127176
2020-11-25 16:06 Bi0T1N Note Edited: 0127176 View Revisions
2020-11-25 16:06 Bi0T1N Note Edited: 0127176 View Revisions
2020-12-28 12:12 CudaText man_ Note Added: 0127852
2020-12-29 16:55 Sven Barth Note Added: 0127899
2020-12-29 17:18 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-12-29 17:18 Michael Van Canneyt Status new => resolved
2020-12-29 17:18 Michael Van Canneyt Resolution open => won't fix
2020-12-29 17:18 Michael Van Canneyt FPCTarget => -
2020-12-29 17:18 Michael Van Canneyt Note Added: 0127906
2020-12-29 18:07 CudaText man_ Status resolved => closed