View Issue Details

IDProjectCategoryView StatusLast Update
0037511pas2jstranspilerpublic2020-08-11 12:57
Reporterhenrique Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMakestubOSWindows 
Summary0037511: Unimplemented?
DescriptionI believe that in the translation for Delphi you have to remove this line, because that reserved word does not exist in Delphi.
TagsNo tags attached.
Fixed in Revision46359
Attached Files

Activities

Michael Van Canneyt

2020-08-08 11:01

administrator   ~0124656

Please give an example.

unit uin;

interface

Procedure DoIt; unimplemented;

implementation

Procedure Doit; unimplemented;

begin
end;

end.

Is translated to

unit uin;

interface

uses jsdelphisystem;

procedure DoIt;


implementation
{$HINTS OFF}
{$WARNINGS OFF}
{$IFDEF FPC}
{$NOTES OFF}
{$ENDIF FPC}

// Dummy implementations for externals


// end of dummy implementations


procedure Doit;
begin
end;


end.

So unimplemented is removed.

henrique

2020-08-10 13:43

reporter   ~0124721

in the SysUtils unit, line 187 has the statement "LeadBytes = [] unimplemented;", the reserved word "unimplemented" does not exist in Delphi and is being kept in variables.

Here a example:
unit Test;

interface

const
  Variable: Integer = 0 unimplemented;
  
implementation

end.

The translation:

unit Test;

interface

uses jsdelphisystem;

const
  Variable : Integer = 0unimplemented;


implementation
{$HINTS OFF}
{$WARNINGS OFF}
{$NOTES OFF}

// Dummy implementations for externals


// end of dummy implementations



end.

Michael Van Canneyt

2020-08-10 14:47

administrator   ~0124724

OK. It is specific to array typed variables. I will check this.

Michael Van Canneyt

2020-08-11 12:57

administrator   ~0124750

Turns out it has to do with constants. Fixed.

Issue History

Date Modified Username Field Change
2020-08-07 21:20 henrique New Issue
2020-08-08 11:01 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-08-08 11:01 Michael Van Canneyt Status new => feedback
2020-08-08 11:01 Michael Van Canneyt Note Added: 0124656
2020-08-10 13:43 henrique Note Added: 0124721
2020-08-10 13:43 henrique Status feedback => assigned
2020-08-10 14:47 Michael Van Canneyt Note Added: 0124724
2020-08-11 12:57 Michael Van Canneyt Status assigned => resolved
2020-08-11 12:57 Michael Van Canneyt Resolution open => fixed
2020-08-11 12:57 Michael Van Canneyt Fixed in Revision => 46359
2020-08-11 12:57 Michael Van Canneyt Note Added: 0124750