View Issue Details

IDProjectCategoryView StatusLast Update
0037521LazarusLCLpublic2020-08-13 04:01
ReporterDavid Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
OSLinux 
Product Version2.0.10 
Summary0037521: Please remove debugln that appears whenever TGtk2WidgetSet.PeekMessage() is called.
DescriptionIn /interfaces/gtk2/gtk2winapi.inc, function TGtk2WidgetSet.PeekMessage() there is a debugln('Peek !!!');
In current trunk its line 0006837, going back to Lazarus 1.8.4 it was 0006717 !

It appears multiple times in my app when its been launched from the command line. And, while harmless it does worry some end users. It looks like, at some stage, someone was chasing a bug in that part of the world, but the debugln has been there for a long time !

Interestingly, it only shows up with particular desktops, I use Mate and see it very reliably, I do know that it does not show up on some other desktops.

I guess its possible that someone was chasing this bug - https://forum.lazarus.freepascal.org/index.php/topic,50628.0.html - I don't know, I have not experienced the bug mentioned there. My issue is far simpler, lets remove that debugln, its not actively being used and it looks unprofessional.

Davo
Steps To ReproduceI am not sure where PeekMessage() is being called from, but just looking at the source, its easy to see whats going to happen when that function is called.
Additional InformationI say 'always' to Reproducibility above because given the right environment, it will always show up. But I suspect a number of desktops don't call that function ....
TagsNo tags attached.
Fixed in Revisionr63704
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Bart Broersma

2020-08-08 15:37

developer   ~0124669

You could provide a patch ...

David

2020-08-09 03:19

reporter   ~0124681

Hmm, or a sed command line ? Honestly, is a patch easier to apply than vi lcl/interfaces/gtk2/gtk2winapi.inc +6837 dd :wq ?

Happy to make one but it seems the hard way to do things ......

Juha Manninen

2020-08-09 08:19

developer   ~0124684

I removed it. Thanks.

David

2020-08-13 04:01

reporter   ~0124816

Thanks !

Issue History

Date Modified Username Field Change
2020-08-08 14:39 David New Issue
2020-08-08 15:37 Bart Broersma Note Added: 0124669
2020-08-09 03:19 David Note Added: 0124681
2020-08-09 08:10 Juha Manninen Assigned To => Juha Manninen
2020-08-09 08:10 Juha Manninen Status new => assigned
2020-08-09 08:19 Juha Manninen Status assigned => resolved
2020-08-09 08:19 Juha Manninen Resolution open => fixed
2020-08-09 08:19 Juha Manninen Fixed in Revision => r63704
2020-08-09 08:19 Juha Manninen LazTarget => -
2020-08-09 08:19 Juha Manninen Widgetset GTK 2 => GTK 2
2020-08-09 08:19 Juha Manninen Note Added: 0124684
2020-08-13 04:01 David Status resolved => closed
2020-08-13 04:01 David Note Added: 0124816