View Issue Details

IDProjectCategoryView StatusLast Update
0037528FPCFCLpublic2020-08-10 13:20
ReporterReiner Sombrowsky Assigned ToMarco van de Voort  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.0 
Summary0037528: TSocket in Unit JwaWinsock2
DescriptionTSocket = Cardinal; // Error

TSocket = UINT_PTR; // Ok
Steps To ReproduceError in CPU64
TagsNo tags attached.
Fixed in Revision46349
FPCOldBugId
FPCTarget-
Attached Files

Activities

Thaddy de Koning

2020-08-10 10:30

reporter   ~0124715

Last edited: 2020-08-10 10:30

View 2 revisions

It is a remnant of its 32 bit origin. I wonder if this is not already fixed upstream by the JEDI people.
I suspect there are more such issues with the FPC fork.

Marco van de Voort

2020-08-10 13:20

manager   ~0124720

committed.

Afaik there is not much activity upstream since before 64-bit Delphi times

Issue History

Date Modified Username Field Change
2020-08-09 16:20 Reiner Sombrowsky New Issue
2020-08-10 10:30 Thaddy de Koning Note Added: 0124715
2020-08-10 10:30 Thaddy de Koning Note Edited: 0124715 View Revisions
2020-08-10 13:20 Marco van de Voort Assigned To => Marco van de Voort
2020-08-10 13:20 Marco van de Voort Status new => resolved
2020-08-10 13:20 Marco van de Voort Resolution open => fixed
2020-08-10 13:20 Marco van de Voort Fixed in Revision => 46349
2020-08-10 13:20 Marco van de Voort FPCTarget => -
2020-08-10 13:20 Marco van de Voort Note Added: 0124720