View Issue Details

IDProjectCategoryView StatusLast Update
0037543pas2jstranspilerpublic2020-08-11 15:25
Reporterhenrique Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMakestubOSWindows 
Fixed in Versiontrunk 
Summary0037543: Implementation of HRESULT
DescriptionWhen I convert the unit classes, which have the HRESULT declaration, the implementation does not use the same return, it generates as Integer, and should be HRESULT.
Steps To Reproducemakestub.exe -i Classes.pas -o ClassesConv.pas
TagsNo tags attached.
Fixed in Revision824
Attached Files

Relationships

related to 0037539 resolvedMichael Van Canneyt The HRESULT 

Activities

Michael Van Canneyt

2020-08-11 15:25

administrator   ~0124762

This is actually the result of your patch in 37539: you only changed the return type in the interface, not in the implementation.

The compiler does not complain since HRESULT and Integer are the same type.
The stub generator takes the function as declared in the implementation...

I changed the implementation to match the interface declaration.

Issue History

Date Modified Username Field Change
2020-08-11 14:23 henrique New Issue
2020-08-11 15:23 Michael Van Canneyt Relationship added related to 0037539
2020-08-11 15:25 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-08-11 15:25 Michael Van Canneyt Status new => resolved
2020-08-11 15:25 Michael Van Canneyt Resolution open => fixed
2020-08-11 15:25 Michael Van Canneyt Fixed in Version => trunk
2020-08-11 15:25 Michael Van Canneyt Fixed in Revision => 824
2020-08-11 15:25 Michael Van Canneyt Note Added: 0124762