View Issue Details

IDProjectCategoryView StatusLast Update
0037544pas2jstranspilerpublic2020-08-12 09:48
Reporterhenrique Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMakestubOSWindows 
Fixed in Versiontrunk 
Summary0037544: Removing overload
DescriptionWhen the original unit has the overload declared, the converted unit is removing the declaration.

I changed the SysUtils unit, and declared an overload not to give compile error in Delphi, but it is removing.

I attached the change.
TagsNo tags attached.
Fixed in Revision826
Attached Files

Relationships

related to 0037510 assignedMichael Van Canneyt Is adding the overload directive 

Activities

henrique

2020-08-11 14:39

reporter  

SysUtils.patch (717 bytes)   
From 6d3c18047a08438e8110578bf1dd4a14e8ff37a5 Mon Sep 17 00:00:00 2001
From: Henrique Gottardi Werlang <henriquewerlang@hotmail.com>
Date: Tue, 11 Aug 2020 09:26:42 -0300
Subject: [PATCH] Adicionado overload.

---
 packages/rtl/sysutils.pas | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/packages/rtl/sysutils.pas b/packages/rtl/sysutils.pas
index 5215f02..4456716 100644
--- a/packages/rtl/sysutils.pas
+++ b/packages/rtl/sysutils.pas
@@ -1254,8 +1254,7 @@ end;
 Type
   TCharSet = Set of Char;
 
-Function CharInSet(Ch: Char;Const CSet : TCharSet) : Boolean;
-
+Function CharInSet(Ch: Char;Const CSet : TCharSet) : Boolean; overload;
 begin
   Result:=Ch in CSet;
 end;
-- 
2.28.0.windows.1

SysUtils.patch (717 bytes)   

henrique

2020-08-11 14:44

reporter   ~0124760

I was wrong, he's just removing the declaration from the implementation part. I believe he removed the overload, in the implementation, because of the other bug that he added to all procedures with the same name.

I attached a new file, with the declarations as expected not to give error in the conversion.
SysUtils-2.patch (1,107 bytes)   
From b16379170d6ebc28e7f7749c7d8261f68ab87102 Mon Sep 17 00:00:00 2001
From: Henrique Gottardi Werlang <henriquewerlang@hotmail.com>
Date: Tue, 11 Aug 2020 09:41:49 -0300
Subject: [PATCH] Adicionado overload.

---
 packages/rtl/sysutils.pas | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/packages/rtl/sysutils.pas b/packages/rtl/sysutils.pas
index 5215f02..d36ff2d 100644
--- a/packages/rtl/sysutils.pas
+++ b/packages/rtl/sysutils.pas
@@ -186,7 +186,7 @@ Const
   HexDisplayPrefix: string = '$';
   LeadBytes = [] unimplemented;
 
-Function CharInSet(Ch: Char;Const CSet : array of char) : Boolean;
+Function CharInSet(Ch: Char;Const CSet : array of char) : Boolean; overload;
 
 function LeftStr(const S: string; Count: Integer): String; assembler;
 function RightStr(const S: string; Count: Integer): String; assembler;
@@ -1254,8 +1254,7 @@ end;
 Type
   TCharSet = Set of Char;
 
-Function CharInSet(Ch: Char;Const CSet : TCharSet) : Boolean;
-
+Function CharInSet(Ch: Char;Const CSet : TCharSet) : Boolean; overload;
 begin
   Result:=Ch in CSet;
 end;
-- 
2.28.0.windows.1

SysUtils-2.patch (1,107 bytes)   

Michael Van Canneyt

2020-08-11 15:38

administrator   ~0124765

Fixed, thanks for the patch !

henrique

2020-08-11 19:59

reporter   ~0124778

Keep removing the overload from line 1257.

Michael Van Canneyt

2020-08-12 09:48

administrator   ~0124785

Fixed in 46367.

Issue History

Date Modified Username Field Change
2020-08-11 14:39 henrique New Issue
2020-08-11 14:39 henrique File Added: SysUtils.patch
2020-08-11 14:44 henrique Note Added: 0124760
2020-08-11 14:44 henrique File Added: SysUtils-2.patch
2020-08-11 15:38 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-08-11 15:38 Michael Van Canneyt Status new => resolved
2020-08-11 15:38 Michael Van Canneyt Resolution open => fixed
2020-08-11 15:38 Michael Van Canneyt Fixed in Version => trunk
2020-08-11 15:38 Michael Van Canneyt Fixed in Revision => 826
2020-08-11 15:38 Michael Van Canneyt Note Added: 0124765
2020-08-11 19:59 henrique Status resolved => feedback
2020-08-11 19:59 henrique Resolution fixed => open
2020-08-11 19:59 henrique Note Added: 0124778
2020-08-12 09:35 Michael Van Canneyt Relationship added related to 0037510
2020-08-12 09:48 Michael Van Canneyt Status feedback => resolved
2020-08-12 09:48 Michael Van Canneyt Resolution open => fixed
2020-08-12 09:48 Michael Van Canneyt Note Added: 0124785