View Issue Details

IDProjectCategoryView StatusLast Update
0037549FPCCompilerpublic2020-08-13 12:02
ReporterCudaText man_ Assigned ToFlorian  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0037549: Improve handling of float consts, handle them as Double instead of Single
DescriptionIssue is shown on forum
https://forum.lazarus.freepascal.org/index.php?topic=50952.0

Jonas wrote about it:
>A bug report would be good, because just using the highest precision in all cases is what we originally did and that caused also compatibility issues. It would also prevent the use of SSE on all x86-64 platforms apart from Win64 as soon as you have a constant, because then the whole expression will suddenly have to be evaluated using extended precision (unless you start explicitly typecasting all of your constants to single/double), and in on all other platforms also have similar effects with expressions only containing single precision values and constants.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Florian

2020-08-11 19:58

administrator   ~0124777

Please submit concrete bug reports and not some random remarks.

Florian

2020-08-11 19:59

administrator   ~0124779

I also do not see the reason why double and not extended or even float128, if available. Just using double is an arbitrary choice.

Issue History

Date Modified Username Field Change
2020-08-11 19:23 CudaText man_ New Issue
2020-08-11 19:58 Florian Assigned To => Florian
2020-08-11 19:58 Florian Status new => resolved
2020-08-11 19:58 Florian Resolution open => no change required
2020-08-11 19:58 Florian Fixed in Version => 3.3.1
2020-08-11 19:58 Florian FPCTarget => -
2020-08-11 19:58 Florian Note Added: 0124777
2020-08-11 19:59 Florian Note Added: 0124779
2020-08-13 12:02 CudaText man_ Status resolved => closed