View Issue Details

IDProjectCategoryView StatusLast Update
0037608LazarusWidgetsetpublic2020-09-21 15:45
ReporterCudaText man Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionopen 
OSUbuntu 20 x64 
Product Version2.1 (SVN) 
Summary0037608: Qt5: MenuItem ImageIndex changing don't fully work
DescriptionDemo
https://github.com/Alexey-T/FreePascal-tests/tree/master/MenuItem%20ImageIndex%20changing

on qt5 the demo 2nd button (change icon of top-2) don't work ok. it must change the icon on each press. here it changes on 1st time.

also I don't see menuitem captions on top level of menu! I see icons.
TagsNo tags attached.
Fixed in Revision63904
LazTarget-
WidgetsetQT5
Attached Files

Relationships

related to 0037741 assignedZeljan Rikalo Qt5: menu RadioItems 

Activities

Zeljan Rikalo

2020-09-21 13:52

developer   ~0125710

Indeed, this is really ugly bug. While I can fix second menuitem (by calling RecreateHandle), first menu item does not show any changes...need some time to investigate inside qt5 libs.

Zeljan Rikalo

2020-09-21 14:29

developer   ~0125714

It is not possible to have text & icon on top menu bar under Qt5.
https://stackoverflow.com/questions/18841141/qmenu-item-text-disappears-when-icon-added

Zeljan Rikalo

2020-09-21 14:32

developer   ~0125715

Please test and close if ok. Note that it's not possible to have icon & text at top level menu items (inside menubar), this is by design in Qt5.

Zeljan Rikalo

2020-09-21 15:03

developer   ~0125717

Must revert, this commit produces mess with menus.

CudaText man_

2020-09-21 15:45

reporter   ~0125718

Waiting for fix.

Issue History

Date Modified Username Field Change
2020-08-20 21:52 CudaText man New Issue
2020-08-24 10:31 Zeljan Rikalo Assigned To => Zeljan Rikalo
2020-08-24 10:31 Zeljan Rikalo Status new => assigned
2020-09-21 13:52 Zeljan Rikalo Status assigned => confirmed
2020-09-21 13:52 Zeljan Rikalo LazTarget => -
2020-09-21 13:52 Zeljan Rikalo Note Added: 0125710
2020-09-21 14:09 Juha Manninen Relationship added related to 0037741
2020-09-21 14:29 Zeljan Rikalo Note Added: 0125714
2020-09-21 14:32 Zeljan Rikalo Status confirmed => resolved
2020-09-21 14:32 Zeljan Rikalo Resolution open => fixed
2020-09-21 14:32 Zeljan Rikalo Fixed in Revision => 63904
2020-09-21 14:32 Zeljan Rikalo Widgetset QT5 => QT5
2020-09-21 14:32 Zeljan Rikalo Note Added: 0125715
2020-09-21 15:03 Zeljan Rikalo Status resolved => assigned
2020-09-21 15:03 Zeljan Rikalo Resolution fixed => open
2020-09-21 15:03 Zeljan Rikalo Note Added: 0125717
2020-09-21 15:45 CudaText man_ Note Added: 0125718