View Issue Details

IDProjectCategoryView StatusLast Update
0037660FPCWebsitepublic2020-08-29 14:39
ReporterBi0T1N Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Fixed in Version3.3.1 
Summary0037660: Remove old news entries from main page
DescriptionRemove news entries from main page as they are already listed under the news page
TagsNo tags attached.
Fixed in Revision1877
FPCOldBugId
FPCTarget3.2.2
Attached Files

Activities

Bi0T1N

2020-08-29 12:15

reporter  

remove_old_entries.patch (2,576 bytes)   
--- fpc.adp.txt	2020-08-29 12:11:06.898076800 +0200
+++ fpc_updated.adp.txt	2020-08-29 12:12:27.707418500 +0200
@@ -85,72 +85,6 @@
 </p>
 
 <p>
- <trn locale="en_US" key="website.frontpage.news_headline_20171127_index">
- <p>
-  <em>November 28th, 2017</em>
- </p>
-  <p>
-   FPC version 3.0.4 has been released!
-   <p>
-    This version is a point update to 3.0 and contains bugfixes and updates packages,
-     some of which are high priority.
-   </p>
-   <p>
-    There is a list of  <a href="http://wiki.freepascal.org/User_Changes_3.0.4">changes that may break backward compatibility</a>.
-    You can also have a look at the <a href="http://www.freepascal.org/docs.var">FPC 3.0.4 documentation</a>.
-   </p>
-   <p>
-    Downloads are available at <a href="http://www.freepascal.org/download.var">the download section</a>.
-   </p>
-   </p>
- </trn>
-</p>
-
-
-<p>
- <trn locale="en_US" key="website.frontpage.news_headline_20170215_index">
- <p>
-  <em>February 15th, 2017</em>
- </p>
- <p>
-   FPC version 3.0.2 has been released!
-   <p>
-    This version is a point update to 3.0 and contains bugfixes and updates packages
-   </p>
-   <p>
-    There is a list of  <a href="http://wiki.freepascal.org/User_Changes_3.0.2">changes that may break backward compatibility</a>.
-    You can also have a look at the <a href="http://www.freepascal.org/docs.var">FPC 3.0.2 documentation</a>.
-   </p>
-   <p>
-    Downloads are available at <a href="http://www.freepascal.org/download.var">the download section</a>.
-   </p>
- </p>
- </trn>
-</p>
-
-
-<p>
- <trn locale="en_US" key="website.frontpage.news_headline_20151125_index">
- <p>
-  <em>November 25th, 2015</em>
- </p>
- <p>
-   FPC version 3.0.0 "Pestering Peacock" has been released!
-   <p>
-    This version includes support for several new platforms, codepage-aware strings and an integrated Pascal source-repository.
-   </p>
-   <p>
-    We have the traditional lists of <a href="http://wiki.freepascal.org/FPC_New_Features_3.0">new features</a> and <a href="http://wiki.freepascal.org/User_Changes_3.0">changes that may break backward compatibility</a>.
-    You can also have a look at the <a href="http://www.freepascal.org/docs.var">FPC 3.0.2 documentation</a>.
-   </p>
-   <p>
-    Downloads are available at <a href="http://www.freepascal.org/download.var">the download section</a>.
-   </p>
- </p>
- </trn>
-</p>
-
-<p>
 <a href="news@x@"><trn locale="en_US" key="website.fpc.older_news">Older news...</trn></a>
 </p>
 <h2><trn locale="en_US" key="website.Current_Version">Current Version</trn></h2>
remove_old_entries.patch (2,576 bytes)   

Bi0T1N

2020-08-29 12:22

reporter   ~0125191

Last edited: 2020-08-29 12:24

View 4 revisions

Is it intended that the first news entry (June 19th, 2020) uses <\l\i> for the date while the others use <\p>? (without \ it's rendered in the comment...)

Michael Van Canneyt

2020-08-29 12:34

administrator   ~0125193

Fixed. Thank you !
Changes will be visible only tomorrow, as the site is only updated during the night.

Bi0T1N

2020-08-29 14:39

reporter   ~0125195

Styling stuff reported in 0037662

Issue History

Date Modified Username Field Change
2020-08-29 12:15 Bi0T1N New Issue
2020-08-29 12:15 Bi0T1N File Added: remove_old_entries.patch
2020-08-29 12:22 Bi0T1N Note Added: 0125191
2020-08-29 12:23 Bi0T1N Note Edited: 0125191 View Revisions
2020-08-29 12:23 Bi0T1N Note Edited: 0125191 View Revisions
2020-08-29 12:24 Bi0T1N Note Edited: 0125191 View Revisions
2020-08-29 12:34 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-08-29 12:34 Michael Van Canneyt Status new => resolved
2020-08-29 12:34 Michael Van Canneyt Resolution open => fixed
2020-08-29 12:34 Michael Van Canneyt Fixed in Version => 3.3.1
2020-08-29 12:34 Michael Van Canneyt Fixed in Revision => 1877
2020-08-29 12:34 Michael Van Canneyt FPCTarget => 3.2.2
2020-08-29 12:34 Michael Van Canneyt Note Added: 0125193
2020-08-29 14:39 Bi0T1N Status resolved => closed
2020-08-29 14:39 Bi0T1N Note Added: 0125195