View Issue Details

IDProjectCategoryView StatusLast Update
0037696FPCPackagespublic2020-09-06 13:21
ReporterReiner Sombrowsky Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.0 
Fixed in Version3.3.1 
Summary0037696: Package winunits-base: Unit RichEdit Error Line 695: EDITSTREAMCALLBACK
DescriptionUnit RichEdit

Error Line 695:
     EDITSTREAMCALLBACK = function (dwCookie:PDWORD; pbBuff:LPBYTE; cb:LONG; var pcb:LONG):DWORD;

It must be:
     EDITSTREAMCALLBACK = function (dwCookie:DWORD_PTR; pbBuff:LPBYTE; cb:LONG; var pcb:LONG):DWORD;
TagsNo tags attached.
Fixed in Revision46762
FPCOldBugId
FPCTarget-
Attached Files

Relationships

has duplicate 0037677 closedBart Broersma Lazarus CCR Unit RichEdi: Line 695: EDITSTREAMCALLBACK .... 

Activities

Bart Broersma

2020-09-04 15:08

reporter   ~0125361

Duplicate of 0037677
Is RichEdit really part of fpc??

Sven Barth

2020-09-04 17:09

manager   ~0125373

@Bart Broersma: We have quite some import units for various Windows libraries.

@Reiner Sombrowsky: Please test and close if okay.

Issue History

Date Modified Username Field Change
2020-09-04 13:34 Reiner Sombrowsky New Issue
2020-09-04 15:08 Bart Broersma Note Added: 0125361
2020-09-04 17:09 Sven Barth Assigned To => Sven Barth
2020-09-04 17:09 Sven Barth Status new => resolved
2020-09-04 17:09 Sven Barth Resolution open => fixed
2020-09-04 17:09 Sven Barth Fixed in Version => 3.3.1
2020-09-04 17:09 Sven Barth Fixed in Revision => 46762
2020-09-04 17:09 Sven Barth FPCTarget => -
2020-09-04 17:09 Sven Barth Note Added: 0125373
2020-09-06 13:21 Bart Broersma Relationship added has duplicate 0037677