View Issue Details

IDProjectCategoryView StatusLast Update
0037698pas2jstranspilerpublic2020-09-05 16:38
Reporterhenrique Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPas2JsOSWindows 
Summary0037698: Startup of the troubled program
DescriptionWhen I place all the unit uses below the implementation, it gives RTL startup error with the error "cannot read property '$initSpec' of undefined".

I've attach a project that occurs the problem.
TagsNo tags attached.
Fixed in Revision46772.
Attached Files

Relationships

has duplicate 0037701 resolvedMattias Gaertner Removing functions 

Activities

henrique

2020-09-04 14:33

reporter  

Error.zip (523 bytes)

Michael Van Canneyt

2020-09-04 14:47

administrator   ~0125359

I can confirm there is an issue. I get the following error:

Uncaught TypeError: pas['Generics.Collections'].TEnumerable$G17 is undefined
    <anonymous> http://localhost:8989/Error.js:1772
    loadintf http://localhost:8989/Error.js:187
    run http://localhost:8989/Error.js:138
    <anonymous> http://localhost:8989/:5

It must have been a recent change because with my previous version compiler it worked OK, when I updated to todays version it broke.

henrique

2020-09-04 14:54

reporter   ~0125360

Last edited: 2020-09-04 14:55

View 2 revisions

That's the error!

I believe it was this last commit, but I need it, which solved other problems!

Which review works?

Issue History

Date Modified Username Field Change
2020-09-04 14:33 henrique New Issue
2020-09-04 14:33 henrique File Added: Error.zip
2020-09-04 14:47 Michael Van Canneyt Assigned To => Mattias Gaertner
2020-09-04 14:47 Michael Van Canneyt Status new => acknowledged
2020-09-04 14:47 Michael Van Canneyt Note Added: 0125359
2020-09-04 14:54 henrique Note Added: 0125360
2020-09-04 14:55 henrique Note Edited: 0125360 View Revisions
2020-09-05 13:53 Mattias Gaertner Relationship added has duplicate 0037701
2020-09-05 13:53 Mattias Gaertner Status acknowledged => resolved
2020-09-05 13:53 Mattias Gaertner Resolution open => fixed
2020-09-05 13:53 Mattias Gaertner Fixed in Revision => 46772.