View Issue Details

IDProjectCategoryView StatusLast Update
0037703FPCDocumentationpublic2020-09-10 08:55
ReporterSven Barth Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.2.0 
Summary0037703: Math.Float is documented as MaxFloatType in 3.0.4, but Extended in 3.2.0
DescriptionIn the documentation for 3.0.4 the type Math.Float is documented as being equivalent to MaxFloatType ( https://www.freepascal.org/docs-html/3.0.2/rtl/math/float.html ). However in the current documentation for 3.2.0 it's documented as Extended ( https://www.freepascal.org/docs-html/rtl/math/float.html ).

Looking at the Math unit this is strange, because it has a special declaration if FpDoc is used ( https://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/rtl/objpas/math.pp?view=markup#l58 ), so probably something went wrong when generating the documentation...
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Marco van de Voort

2020-09-04 17:05

manager   ~0125371

I think fpdoc sees both float = statements, the fpdoc_math ifdefed and the later has_extended one.

Michael Van Canneyt

2020-09-10 08:55

administrator   ~0125456

Fixed by shuffling the defines

Issue History

Date Modified Username Field Change
2020-09-04 16:51 Sven Barth New Issue
2020-09-04 16:51 Sven Barth Status new => assigned
2020-09-04 16:51 Sven Barth Assigned To => Michael Van Canneyt
2020-09-04 17:05 Marco van de Voort Note Added: 0125371
2020-09-10 08:55 Michael Van Canneyt Status assigned => resolved
2020-09-10 08:55 Michael Van Canneyt Resolution open => fixed
2020-09-10 08:55 Michael Van Canneyt FPCTarget => -
2020-09-10 08:55 Michael Van Canneyt Note Added: 0125456