View Issue Details

IDProjectCategoryView StatusLast Update
0037732LazarusWidgetsetpublic2020-09-18 12:01
ReporterCudaText man Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
OSWin10, Win7 
Product Version2.1 (SVN) 
Summary0037732: Win32: bad window behavior after Restore from minimized state
DescriptionDemo (with exe, so you can test this Laz version's exe)

- maximize window
- minimize window
- click Win10 taskbar btn to restore
-> it's restored to NOT maximized state
TagsNo tags attached.
Fixed in Revisionr63882, r63888
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0036127 resolvedJuha Manninen [Patch] TForm's bounds and restored bounds are inconsistent 

Activities

CudaText man

2020-09-10 22:35

reporter  

win-min.png (13,869 bytes)   
win-min.png (13,869 bytes)   
tst-dummy.zip (922,740 bytes)

CudaText man

2020-09-10 22:36

reporter   ~0125464

More info

- I cannot repeat it on my Win10 x64 2004, but 2 users of CudaText can
- talks here https://github.com/Alexey-T/CudaText/issues/2830

jamie philbrook

2020-09-10 23:47

reporter   ~0125466

I have three windows 10 PC's here with a variety of Lazarus installs of release versions, no trunks..

They all behave correctly.

 So maybe it's the fact that the trunk is being used could be a factor.

wp

2020-09-10 23:49

developer   ~0125467

Last edited: 2020-09-10 23:50

View 2 revisions

I see the same issue on Win 10 (v2004)/64 bit when I do this

- Start Lazarus trunk
- Click the "minimize" button in the title bar --> the app does not disappear in the task bar but remains as a minimized window in the work as - exactly as Alexey shows in his screen shot
- When I click the Lazarus icon in the task bar, Lazarus comes up again, but has an extraordinaily high main window. The component palette is about 430 pixels high while it has a height of about 50 pixels normally
- When I drag the bottom edge of that super-high main window the height suddenly jumps back its normal value.

Since this issue occured only recently it was easy to find the guilty revision: it is r63842 ("LCL: Improve TForm's bounds events. Issue 0036127, patch from Joeny Ang.", committed by Juha).

Juha, I hope you don't mind that I assign this report to you.

Juha Manninen

2020-09-11 20:03

developer   ~0125487

Ok, I reverted r63842 in r63882. Please test.
Reopening the related issue.

wp

2020-09-11 20:38

developer   ~0125489

Works correctly again, for me.

CudaText man_

2020-09-11 20:43

reporter   ~0125490

Works OK now.

Juha Manninen

2020-09-18 12:01

developer   ~0125611

This seems to work also after r63888 (issue 0036127). Resolving.

Issue History

Date Modified Username Field Change
2020-09-10 22:35 CudaText man New Issue
2020-09-10 22:35 CudaText man File Added: win-min.png
2020-09-10 22:35 CudaText man File Added: tst-dummy.zip
2020-09-10 22:36 CudaText man Note Added: 0125464
2020-09-10 23:47 jamie philbrook Note Added: 0125466
2020-09-10 23:49 wp Note Added: 0125467
2020-09-10 23:49 wp Relationship added related to 0036127
2020-09-10 23:50 wp Note Edited: 0125467 View Revisions
2020-09-10 23:50 wp Assigned To => Juha Manninen
2020-09-10 23:50 wp Status new => assigned
2020-09-11 20:03 Juha Manninen Note Added: 0125487
2020-09-11 20:38 wp Note Added: 0125489
2020-09-11 20:43 CudaText man_ Note Added: 0125490
2020-09-18 12:01 Juha Manninen Status assigned => resolved
2020-09-18 12:01 Juha Manninen Resolution open => fixed
2020-09-18 12:01 Juha Manninen Fixed in Revision => r63882, r63888
2020-09-18 12:01 Juha Manninen LazTarget => -
2020-09-18 12:01 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2020-09-18 12:01 Juha Manninen Note Added: 0125611