View Issue Details

IDProjectCategoryView StatusLast Update
0037747FPCPackagespublic2020-12-09 14:17
ReporterSimon Booth Assigned ToMichael Van Canneyt  
Status resolvedResolutionfixed 
Product Version3.2.0 
Fixed in Version3.3.1 
Summary0037747: https / ssl failure using example program
DescriptionHTTPS connections fail to certain domains while others are fine

It is notable that the big sites all work while smaller ones tend to fail (whitelisting?)

This has been observed on current versions of both MacOSX and iOS
Steps To ReproduceGo to
 and locate dl_fphttp_c

Compile and run it (everything is fine)

Alter the URL fetched from to

Compile and run it (everything is NOT fine)

An unhandled exception occurred at $000000010D02A192:
ESocketError: Connect to failed.
TagsNo tags attached.
Fixed in Revision46987
Attached Files



2020-09-14 18:03

reporter   ~0125540

Probably the same issue as reported on the forum:,50350.msg373929.html#msg373929

Michael Van Canneyt

2020-09-14 18:57

administrator   ~0125541

Yes. It works on Linux, the issue is particular to macos. There is a bugreport with fix, still needs to be checked, planned for next weekend.

Simon Booth

2020-09-15 01:06

reporter   ~0125544

If someone can point me at a bug-fixed fphttp the app I'm developing will test it nicely. It downloads 1.5g of data in 13,325 files from a variety of sources that currently fails under MacOS but work on everything else I've tried it on (tested on Win10, Linux x64 + Aarch64 so far).

A smaller-scale test is also ready to check iOS which will be expanded to the full test when MacOS works.

Michael Van Canneyt

2020-09-15 05:11

administrator   ~0125545

Please have patience.

As I said, this is known and will be fixed, but this is an open source project, and I need time to fix it.
You can fix it yourself with the patch mentioned in the forum post (see Bi0T1N's reply) or you can wait till I do it.

Simon Booth

2020-09-15 12:12

reporter   ~0125549

I am patient (sometimes <g>)

Anyway I read the forum post properly and found the fix so am just trying it out

My test is running nicely and ha currently grabbed 50Mb in 542 files while I typed this reply

Simon Booth

2020-09-15 22:00

reporter   ~0125561

A quick FYI - my test has finished, 13,325 files (1.5G) all downloaded correctly with patched openssl

Michael Van Canneyt

2020-09-28 13:30

administrator   ~0125924

Solved slightly differently than proposed in the forum.
The LibreSSL support is configurable. It is loaded first on Mac, last on Linux.
On Windows there is currently no difference.


2020-09-30 21:05

reporter   ~0126011

Last edited: 2020-10-01 17:55

View 2 revisions

Michael, your patch removes a feature where you could specify the libraries to use. DLLSSLName and DLLSSLName2 were variables.

For example:
DLLSSLName := 'C:/Something/ssleay32.dll';

I think your patch should make BaseSSLName and BaseCryptoName variables to restore this feature.

Michael Van Canneyt

2020-10-01 08:48

administrator   ~0126016

Ah. I will look at this, sorry about that.
But I will do this differently by explicitly specifying the library names to use to InitSSLInterface()


2020-10-01 17:55

reporter   ~0126026

That would be even better, thanks.

jach hunter

2020-12-09 12:52

reporter   ~0127475

Compile and run it (everything is NOT fine)

An unhandled exception occurred at $000000010D02A192:
ESocketError: Connect to failed.

Thanks thanks!

Michael Van Canneyt

2020-12-09 14:17

administrator   ~0127481

The example is of course wrong. Did you add the opensslsockets unit to the uses clause ?
After that change, it works fine on Mac OS big Sur.
If you still discover an issue, please open a new issue.

Issue History

Date Modified Username Field Change
2020-09-14 16:32 Simon Booth New Issue
2020-09-14 18:03 Bi0T1N Note Added: 0125540
2020-09-14 18:57 Michael Van Canneyt Note Added: 0125541
2020-09-15 01:06 Simon Booth Note Added: 0125544
2020-09-15 05:08 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-09-15 05:08 Michael Van Canneyt Status new => assigned
2020-09-15 05:11 Michael Van Canneyt Note Added: 0125545
2020-09-15 12:12 Simon Booth Note Added: 0125549
2020-09-15 22:00 Simon Booth Note Added: 0125561
2020-09-28 13:30 Michael Van Canneyt Status assigned => resolved
2020-09-28 13:30 Michael Van Canneyt Resolution open => fixed
2020-09-28 13:30 Michael Van Canneyt Fixed in Version => 3.3.1
2020-09-28 13:30 Michael Van Canneyt Fixed in Revision => 46987
2020-09-28 13:30 Michael Van Canneyt FPCTarget => 3.2.2
2020-09-28 13:30 Michael Van Canneyt Note Added: 0125924
2020-09-30 21:05 olly Note Added: 0126011
2020-10-01 08:48 Michael Van Canneyt Note Added: 0126016
2020-10-01 17:55 olly Note Added: 0126026
2020-10-01 17:55 olly Note Edited: 0126011 View Revisions
2020-12-09 12:52 jach hunter Note Added: 0127475
2020-12-09 14:17 Michael Van Canneyt Note Added: 0127481