View Issue Details

IDProjectCategoryView StatusLast Update
0037748FPCCompilerpublic2020-09-15 22:15
ReporterIgor Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.2.0 
Summary0037748: Internal class types visibility error
DescriptionAttached module compilation produces errors:

testunit.pas(21,9) Error: Duplicate identifier "teFirst"
testunit.pas(21,16) Hint: Identifier already defined in testunit.pas at line 12
testunit.pas(22,9) Error: Duplicate identifier "teSecond"
testunit.pas(23,7) Hint: Identifier already defined in testunit.pas at line 13
Steps To ReproduceCompile the attached module
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0037749 resolvedSven Barth Internal class enumeration visibility error 

Activities

Sven Barth

2020-09-15 13:24

manager   ~0125547

Last edited: 2020-09-15 13:25

View 2 revisions

It seems that you forgot to attach the test file.

Edit: Is this the same issue as 0037749 (where you did attach a test file)?

Sven Barth

2020-09-15 22:15

manager   ~0125556

I'm resolving this as a duplicate to 0037749, cause it definitely reads similar.

Issue History

Date Modified Username Field Change
2020-09-15 12:31 Igor New Issue
2020-09-15 13:24 Sven Barth Assigned To => Sven Barth
2020-09-15 13:24 Sven Barth Status new => feedback
2020-09-15 13:24 Sven Barth FPCTarget => -
2020-09-15 13:24 Sven Barth Note Added: 0125547
2020-09-15 13:25 Sven Barth Note Edited: 0125547 View Revisions
2020-09-15 22:15 Sven Barth Status feedback => resolved
2020-09-15 22:15 Sven Barth Resolution open => duplicate
2020-09-15 22:15 Sven Barth Note Added: 0125556
2020-09-15 22:15 Sven Barth Relationship added duplicate of 0037749