View Issue Details

IDProjectCategoryView StatusLast Update
0037773pas2jstranspilerpublic2020-09-19 09:53
Reporterhenrique Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPas2JsOSWindows 
Summary0037773: Better names for generics
DescriptionI modified the function that generates the name of generic classes in JS to conform to the PAS implementation.

I was attaching names that shouldn't, such as: "TMyType<TypeX<TypeY><TypeY>>"
TagsNo tags attached.
Fixed in Revision
Attached Files

Activities

henrique

2020-09-18 19:08

reporter  

Names.patch (1,143 bytes)   
From 3e0b42cf896a272814a1f2575065804848f145b2 Mon Sep 17 00:00:00 2001
From: Henrique Gottardi Werlang <henriquewerlang@hotmail.com>
Date: Thu, 17 Sep 2020 14:30:11 -0300
Subject: [PATCH] =?UTF-8?q?Ajustado=20a=20nome=C3=A7=C3=A3o=20dos=20generi?=
 =?UTF-8?q?cs.?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

---
 packages/fcl-passrc/src/pasresolver.pp | 6 ------
 1 file changed, 6 deletions(-)

diff --git a/packages/fcl-passrc/src/pasresolver.pp b/packages/fcl-passrc/src/pasresolver.pp
index ec7f76cf32..7d87f06ca1 100644
--- a/packages/fcl-passrc/src/pasresolver.pp
+++ b/packages/fcl-passrc/src/pasresolver.pp
@@ -16740,12 +16740,6 @@ function TPasResolver.CreateSpecializedTypeName(Item: TPRSpecializedItem): strin
       else
         Result:=aType.GetModule.Name;
       Result:=Result+'.'+aType.Name;
-      if aType.CustomData is TPasGenericScope then
-        begin
-        ChildItem:=TPasGenericScope(aType.CustomData).SpecializedFromItem;
-        if ChildItem<>nil then
-          Result:=Result+GetSpecParams(ChildItem);
-        end;
       end;
   end;
 
-- 
2.28.0.windows.1

Names.patch (1,143 bytes)   

Michael Van Canneyt

2020-09-19 09:37

administrator   ~0125637

Mattias is reworking the naming system for generics, better wait till he has finished the work.

Mattias Gaertner

2020-09-19 09:53

manager   ~0125638

The FPC names are already generated since a week. Henrique, please update your svn.

Issue History

Date Modified Username Field Change
2020-09-18 19:08 henrique New Issue
2020-09-18 19:08 henrique File Added: Names.patch
2020-09-19 09:37 Michael Van Canneyt Note Added: 0125637
2020-09-19 09:37 Michael Van Canneyt Assigned To => Mattias Gaertner
2020-09-19 09:37 Michael Van Canneyt Status new => assigned
2020-09-19 09:53 Mattias Gaertner Note Added: 0125638
2020-09-19 09:53 Mattias Gaertner Status assigned => resolved
2020-09-19 09:53 Mattias Gaertner Resolution open => fixed