View Issue Details

IDProjectCategoryView StatusLast Update
0037792LazarusPackagespublic2020-10-10 18:22
ReporterCudaText man_ Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionwon't fix 
Product Version2.1 (SVN) 
Summary0037792: feature req: FileUtil.TFileSearcher excluding file/folder masks
DescriptionVery often app needs to search in subdirs EXCEPT .git .svn and some others. So some excluding folder masks are needed.
Also excluding file masks are needed, e.g. to exclude dot-names, or some bad file extensions.

If it will be 2 new properties, code will be backward compatible.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0037790 new FileUtil.FindAllFiles runs forever, because of symlinks 

Activities

Bart Broersma

2020-09-21 23:16

developer   ~0125743

Can't you use OnDirectoryFound for that?

Bart Broersma

2020-10-10 18:20

developer   ~0126221

Please close.

Issue History

Date Modified Username Field Change
2020-09-21 20:29 CudaText man_ New Issue
2020-09-21 23:16 Bart Broersma Note Added: 0125743
2020-09-21 23:19 Bart Broersma Relationship added related to 0037790
2020-10-10 18:20 Bart Broersma Assigned To => Bart Broersma
2020-10-10 18:20 Bart Broersma Status new => resolved
2020-10-10 18:20 Bart Broersma Resolution open => won't fix
2020-10-10 18:20 Bart Broersma LazTarget => -
2020-10-10 18:20 Bart Broersma Note Added: 0126221
2020-10-10 18:22 CudaText man_ Status resolved => closed