View Issue Details

IDProjectCategoryView StatusLast Update
0037801LazarusLCLpublic2020-09-23 16:30
ReporterAndrea Mauri Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.10 
Summary0037801: TEdit.NumbersOnly does not work on cocoa and gtk2
DescriptionTEdit behaviour when NumbersOnly = True is different between Windows and Mac/Linux.
When NumbersOnly = True on Windows it is not allowed to type any character different from digits in the TEdit.
On mac (cocoa) and Linux (gtk2) with NumbersOnly = True I can still type any character in the TEdit.

Lazarus 2.0.11 r63871 FPC 3.2.0 x86_64-darwin-cocoa

Forum Post:
https://forum.lazarus.freepascal.org/index.php?topic=51549.0
Steps To ReproducePlace a TEdit on a form, set NumbersOnly = True. Run the project.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2, Cocoa
Attached Files

Relationships

duplicate of 0033704 resolvedBart Broersma TEdit NumbersOnly does not work under Linux Mint & Ubuntu 

Activities

Bart Broersma

2020-09-23 16:29

developer   ~0125778

As explained in the forum: this only ever was supposed to work on widgetsets that support this.

Issue History

Date Modified Username Field Change
2020-09-23 15:15 Andrea Mauri New Issue
2020-09-23 16:29 Bart Broersma Note Added: 0125778
2020-09-23 16:30 Bart Broersma Assigned To => Bart Broersma
2020-09-23 16:30 Bart Broersma Status new => resolved
2020-09-23 16:30 Bart Broersma Resolution open => duplicate
2020-09-23 16:30 Bart Broersma LazTarget => -
2020-09-23 16:30 Bart Broersma Widgetset GTK 2, Cocoa => GTK 2, Cocoa
2020-09-23 16:30 Bart Broersma Relationship added duplicate of 0033704