View Issue Details

IDProjectCategoryView StatusLast Update
0037858LazarusIDEpublic2020-10-07 22:16
ReporterSven Barth Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformX86_64OSWindows NT 
Product Version2.1 (SVN) 
Fixed in Version2.2 
Summary0037858: HighDPI: Icon to stop macro recording not scaled correctly
DescriptionWhen recording a macro (which happens to me mainly on accident) on a High DPI system (Windows 10 200%) the icon/button to stop the recording of the macro is not scaled correctly, thus kinda hard to hit.
TagsNo tags attached.
Fixed in Revision63964
LazTarget2.2
WidgetsetWin32/Win64
Attached Files

Activities

Sven Barth

2020-10-02 22:17

manager  

Martin Friebe

2020-10-03 16:59

manager   ~0126064

Since I have no setup to test this, could you please check with r63949
Thanks

Sven Barth

2020-10-04 13:47

manager   ~0126077

Partially. The area now seems to have the correct size, but the icon is still small (and it stops recording correctly when clicked outside of the icon, but inside the area).

See attached screenshot.

Sven Barth

2020-10-07 22:16

manager   ~0126130

Looks good. :)

Issue History

Date Modified Username Field Change
2020-10-02 22:17 Sven Barth New Issue
2020-10-02 22:17 Sven Barth File Added: lazarus-highdpi-macro-recording.png
2020-10-03 16:39 Martin Friebe Assigned To => Martin Friebe
2020-10-03 16:39 Martin Friebe Status new => assigned
2020-10-03 16:59 Martin Friebe Status assigned => feedback
2020-10-03 16:59 Martin Friebe LazTarget => -
2020-10-03 16:59 Martin Friebe Note Added: 0126064
2020-10-04 13:47 Sven Barth Note Added: 0126077
2020-10-04 13:47 Sven Barth File Added: lazarus-highdpi-macro-recording-2.png
2020-10-04 13:47 Sven Barth Status feedback => assigned
2020-10-06 20:16 Martin Friebe Status assigned => resolved
2020-10-06 20:16 Martin Friebe Resolution open => fixed
2020-10-06 20:16 Martin Friebe Fixed in Version => 2.2
2020-10-06 20:16 Martin Friebe Fixed in Revision => 63964
2020-10-06 20:16 Martin Friebe LazTarget - => 2.2
2020-10-06 20:16 Martin Friebe Widgetset Win32/Win64 => Win32/Win64
2020-10-07 22:16 Sven Barth Status resolved => closed
2020-10-07 22:16 Sven Barth Note Added: 0126130