View Issue Details

IDProjectCategoryView StatusLast Update
0037903pas2jsrtlpublic2020-10-23 13:15
Reporterhenrique Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPas2JsOSWindows 
Fixed in Versiontrunk 
Summary0037903: Long string in DFM
DescriptionWhen a very large string is filled within DFM, Delphi places the sign ("+") to split the string into smaller parts, but this is giving an invalid token error.

I attached a correction, creating a new token type for the plus sign.
TagsNo tags attached.
Fixed in Revision901
Attached Files

Activities

henrique

2020-10-09 20:58

reporter  

Classes.patch (448 bytes)   
diff -r packages/rtl/classes.pas (88ca854d) packages/rtl/classes.pas (Working Tree)
1252c1252,1253
<                   toColon // :
---
>                   toColon, // :
>                   toPlus // +
9846c9847,9848
<     ':'
---
>     ':',
>     '+'
10253a10256
>       '+' : SetToken(toPlus);
10382c10385
<   while (parser.NextToken = classes.toString) and (Parser.TokenString='+') do
---
>   while parser.NextToken = toPlus do
Classes.patch (448 bytes)   

henrique

2020-10-14 13:09

reporter   ~0126293

this will be applied?

Michael Van Canneyt

2020-10-23 12:35

administrator   ~0126486

I'm not entirely satisfied with the new + token, since it introduces an incompatibility but I have no better alternative.

Thank you for the patch !

Issue History

Date Modified Username Field Change
2020-10-09 20:58 henrique New Issue
2020-10-09 20:58 henrique File Added: Classes.patch
2020-10-14 13:09 henrique Note Added: 0126293
2020-10-23 12:09 Mattias Gaertner Assigned To => Michael Van Canneyt
2020-10-23 12:09 Mattias Gaertner Status new => assigned
2020-10-23 12:35 Michael Van Canneyt Status assigned => resolved
2020-10-23 12:35 Michael Van Canneyt Resolution open => fixed
2020-10-23 12:35 Michael Van Canneyt Fixed in Version => trunk
2020-10-23 12:35 Michael Van Canneyt Fixed in Revision => 901
2020-10-23 12:35 Michael Van Canneyt Note Added: 0126486