View Issue Details

IDProjectCategoryView StatusLast Update
0037910FPCRTLpublic2020-10-11 15:08
ReporterWolfgang Helbig Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformimacOSos x 
Product Version3.2.0 
Summary0037910: -gl option does not work: 10.6 Line numbers in run-time error backtraces
DescriptionThe program is compiled with -gl, but the line number is not reported with the runtime error message:
{$MODE ISO}
program stack (output);
var p: ^ integer;
begin
  p := nil;
  writeln(p^)
end.
$ fpc -gl stack.p
$ stack
Runtime error 216 at $000000010668CBB4
  $000000010668CBB4

This contrasts with the users guide, 10.6:
When compiled with -gl, the following output is generated:
Runtime error 255 at 0x0040BDE5
  0x0040BDE5 GENERATEERROR255, line 6 of testline.pp
  0x0040BDF0 GENERATEANERROR, line 13 of testline.pp
  0x0040BE0C main, line 17 of testline.pp
  0x0040B7B1
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0032775 new The combination of -gh and -gl does not give line number information 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-10-11 15:02 Wolfgang Helbig New Issue
2020-10-11 15:08 Jonas Maebe Assigned To => Jonas Maebe
2020-10-11 15:08 Jonas Maebe Status new => resolved
2020-10-11 15:08 Jonas Maebe Resolution open => duplicate
2020-10-11 15:08 Jonas Maebe FPCTarget => -
2020-10-11 15:08 Jonas Maebe Relationship added duplicate of 0032775