View Issue Details

IDProjectCategoryView StatusLast Update
0037917PackagesPackagespublic2020-10-13 12:08
ReporterHugo Barwich Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Summary0037917: Docs RPM Build of fpc fails because latex pdf documents fail to build
DescriptionI try to repackage the FPC Compiler for Centos7
When I execute the ".spec" file I get an errror due to missing dependencies.

$ rpmbuild -bb ../SPECS/fpc-3.2.0.spec
Loading messagefile ../compiler/msg/errore.msg
Writing TeXfile messages.inc
/usr/bin/echo % Automatically generated Unix version. Do not edit > comphelp.inc
/usr/bin/echo -n "\\begin{verbatim}" >> comphelp.inc
/home/usr15/rpmbuild/BUILD/fpc-3.2.0/compiler/ppcx64 -h | sed 's;\\;\\\\;g' >> comphelp.inc
/usr/bin/echo "\\end{verbatim}" >> comphelp.inc
rm -f user.aux user.idx user.ilg user.ind user.log user.out user.toc user.tmp user.xref user.4ht
cp -f preamble.report preamble.inc
pdflatex user
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013)
 restricted \write18 enabled.
entering extended mode
(./user.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, lo
aded.
(./preamble.inc (/usr/share/texlive/texmf-dist/tex/latex/base/report.cls
Document Class: report 2007/10/19 v1.4h Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size10.clo
kpathsea: Running mktextfm cmr10
/usr/share/texlive/texmf/web2c/mktexnam: Could not map source abbreviation for cmr10.
/usr/share/texlive/texmf/web2c/mktexnam: Need to update ?
mktextfm: Running mf \mode:=ljfour; mag:=1; nonstopmode; input cmr10
/usr/bin/mktextfm: line 96: mf: command not found
grep: cmr10.log: No such file or directory
mktextfm: `mf \mode:=ljfour; mag:=1; nonstopmode; input cmr10' failed to make cmr10.tfm.
kpathsea: Appending font creation commands to missfont.log.

! Font OT1/cmr/m/n/10=cmr10 at 10.0pt not loadable: Metric (TFM) file not found
.
<to be read again>
                   relax
l.64 \normalsize
? ^C! Interruption.
extract@font ...ont font@name external@font relax
                                                  font@name relax csname f@e...
l.64 \normalsize
?
Type <return> to proceed, S to scroll future error messages,
R to run without stopping, Q to run quietly,
I to insert something, E to edit your file,
H for help, X to quit.
?
! Emergency stop.
extract@font ...ont font@name external@font relax
                                                  font@name relax csname f@e...
l.64 \normalsize
! ==> Fatal error occurred, no output PDF file produced!
Transcript written on user.log.
make: *** [user.pdf] Error 1

I use the Binary Package provides by the Official Centos Repository:
$ yum info texlive-latex-bin-bin
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.airenetworks.es
 * epel: mirror.in2p3.fr
 * extras: mirror.airenetworks.es
 * nux-dextop: li.nux.ro
 * rpmforge: ftp.nluug.nl
 * updates: mirror.airenetworks.es
Available Packages
Name : texlive-latex-bin-bin
Arch : noarch
Epoch : 2
Version : svn14050.0
Release : 45.20130427_r30134.el7
Size : 18 k
Repo : base/7/x86_64
Summary : Binaries for latex-bin
URL : http://tug.org/texlive/
Licence : Artistic 2.0 and GPLv2 and GPLv2+ and LGPLv2+ and LPPL and MIT and Public Domain and
            : UCD and Utopia
Description : Binaries for latex-bin

Beside of some missing dependency for a Command Line Utility it would be more practical to have MAN Pages rather than PDF Documents.
Steps To Reproduce$ cat /etc/centos-release
CentOS Linux release 7.7.1908 (Core)
# yum install texlive-latex-bin-bin
$ rpm2cpio fpc-3.2.0-1.src.rpm | cpio -idm
$ mv fpc-3.2.0.spec ../SPECS/
$ rpmbuild -bb ../SPECS/fpc-3.2.0.spec
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 3
Attached Files

Activities

Hugo Barwich

2020-10-13 11:53

reporter   ~0126277

As a workaround I modified the ".spec" file:

%build
NODOCS=1
%install
NODOCS=1
%files docs
#%doc %{docdir}/*.pdf

I really would like to read the documentation. But rather as MAN Pages.

Michael Van Canneyt

2020-10-13 12:06

administrator   ~0126278

Look at this line:

/usr/bin/mktextfm: line 96: mf: command not found

The metafont part of Latex is not correctly installed or configured.

Marco van de Voort

2020-10-13 12:08

manager   ~0126279

The docs are quite big, I don't think that would be practical.

Futhermore, the problem is not really the input and the spec, but the missing of fonts. Maybe there is some centos (and version) specific builddepends necessary to get the relevant fonts.

Issue History

Date Modified Username Field Change
2020-10-13 11:50 Hugo Barwich New Issue
2020-10-13 11:53 Hugo Barwich Note Added: 0126277
2020-10-13 12:06 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-10-13 12:06 Michael Van Canneyt Status new => resolved
2020-10-13 12:06 Michael Van Canneyt Resolution open => no change required
2020-10-13 12:06 Michael Van Canneyt LazTarget => -
2020-10-13 12:06 Michael Van Canneyt Widgetset GTK 3 => GTK 3
2020-10-13 12:06 Michael Van Canneyt Note Added: 0126278
2020-10-13 12:08 Marco van de Voort Note Added: 0126279