View Issue Details

IDProjectCategoryView StatusLast Update
0037943LazarusWidgetsetpublic2020-12-29 10:37
ReporterCudaText man_ Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
OSUbuntu 20 x64 
Product Version2.1 (SVN) 
Summary0037943: gtk2: If OpenDialog was called, app gives AV on closing
DescriptionOpen demo from terminal.
a) open and close. no errors in terminal.
b) open, press btn to call OpenDialog, choose some file.
An unhandled exception occurred at $00007FD1450FB203:
EAccessViolation:
  $00007FD1450FB203
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

CudaText man_

2020-10-17 10:12

reporter  

tst-opendlg.zip (1,779 bytes)

Juha Manninen

2020-10-17 13:17

developer   ~0126364

I cannot reproduce. Maybe again something specific to Ubuntu. Can others reproduce?

Anton Kavalenka

2020-10-17 13:49

reporter   ~0126365

Can not reproduce. Debian 10.6

Bart Broersma

2020-10-17 15:21

developer   ~0126368

Last edited: 2020-10-17 15:41

View 2 revisions

Cannot reproduce with Lazarus trunk of today and fpc 3.0.4 on Mint 18.2
Just tested with fpc 3.2.0: same result.

CudaText man_

2020-10-22 22:49

reporter   ~0126477

Smth is wrong with my 2nd PC. no repro on 1st PC.

CudaText man_

2020-12-27 13:07

reporter   ~0127814

please close.

Juha Manninen

2020-12-27 14:35

developer   ~0127816

Resolving.

Issue History

Date Modified Username Field Change
2020-10-17 10:12 CudaText man_ New Issue
2020-10-17 10:12 CudaText man_ File Added: tst-opendlg.zip
2020-10-17 13:17 Juha Manninen Note Added: 0126364
2020-10-17 13:49 Anton Kavalenka Note Added: 0126365
2020-10-17 15:21 Bart Broersma Note Added: 0126368
2020-10-17 15:41 Bart Broersma Note Edited: 0126368 View Revisions
2020-10-22 22:49 CudaText man_ Note Added: 0126477
2020-12-27 13:07 CudaText man_ Note Added: 0127814
2020-12-27 14:35 Juha Manninen Assigned To => Juha Manninen
2020-12-27 14:35 Juha Manninen Status new => resolved
2020-12-27 14:35 Juha Manninen Resolution open => no change required
2020-12-27 14:35 Juha Manninen LazTarget => -
2020-12-27 14:35 Juha Manninen Widgetset GTK 2 => GTK 2
2020-12-27 14:35 Juha Manninen Note Added: 0127816
2020-12-29 10:37 CudaText man_ Status resolved => closed