View Issue Details

IDProjectCategoryView StatusLast Update
0037947FPCUtilitiespublic2020-11-08 19:01
ReporterTotoliciu Denis Dan Assigned ToFlorian  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version3.2.0 
Summary0037947: Update the `make` utility to a newer version
Description`make.exe` version 3.80 that is currently in the FPC \bin directory has a problem with the `$(lastword)` function.
It doesn't return the last word from the given list of words. The result is an empty value.
Have tested the same routine on version 3.81 and it works.
Steps To ReproduceRun the attached `Makefile` with the `make` utility.

Expected: output the word `you`.
Actual:
(v3.80) ECHO is off.
(v3.81) you

Version 3.80 outputs `ECHO is off.` because variable `v1` is empty.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Totoliciu Denis Dan

2020-10-17 22:53

reporter   ~0126380

Here is the `Makefile`:
Makefile (59 bytes)   
v1 = $(lastword hello how are you)

deft:
	@echo $(v1)
Makefile (59 bytes)   

Tomas Hajny

2020-10-17 23:52

manager   ~0126383

Which operating system / platform do you mean?

Totoliciu Denis Dan

2020-10-18 21:04

reporter   ~0126406

Windows 7 64-bit

Florian

2020-11-08 19:01

administrator   ~0126801

The official windows installer comes with 3.82.

Issue History

Date Modified Username Field Change
2020-10-17 22:49 Totoliciu Denis Dan New Issue
2020-10-17 22:53 Totoliciu Denis Dan Note Added: 0126380
2020-10-17 22:53 Totoliciu Denis Dan File Added: Makefile
2020-10-17 23:52 Tomas Hajny Assigned To => Tomas Hajny
2020-10-17 23:52 Tomas Hajny Status new => feedback
2020-10-17 23:52 Tomas Hajny FPCTarget => -
2020-10-17 23:52 Tomas Hajny Note Added: 0126383
2020-10-18 00:14 Tomas Hajny Assigned To Tomas Hajny =>
2020-10-18 21:04 Totoliciu Denis Dan Note Added: 0126406
2020-10-18 21:04 Totoliciu Denis Dan Status feedback => new
2020-11-08 19:01 Florian Assigned To => Florian
2020-11-08 19:01 Florian Status new => resolved
2020-11-08 19:01 Florian Resolution open => no change required
2020-11-08 19:01 Florian Note Added: 0126801