View Issue Details

IDProjectCategoryView StatusLast Update
0037948LazarusDocumentationpublic2020-10-19 00:24
ReporterDon Siders Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version2.1 (SVN) 
Summary0037948: Added LazUtils documentation file: filereferencelist.xml
DescriptionAdded a new file in LazUtils with topic skeletons.

See attached: filereferencelist.xml
TagsNo tags attached.
Fixed in Revisionr64044
LazTarget-
Widgetset
Attached Files

Activities

Don Siders

2020-10-18 00:40

reporter  

filereferencelist.xml (5,217 bytes)   
<?xml version="1.0" encoding="UTF-8"?>
<fpdoc-descriptions>
  <package name="lazutils">
    <!--
      ====================================================================
        FileReferenceList
      ====================================================================
    -->
    <module name="FileReferenceList">
      <short>Contains types and classes used to implement a list of file references</short>
      <descr>
        <p>
          Implements the TFileReference and TFileReferenceList classes. Provides a list of file references with counters and a search path for all files.
        </p>
        <p>
          Author: Mattias Gaertner
        </p>
      </descr>

      <!-- unresolved external references -->
      <element id="Classes"/>
      <element id="SysUtils"/>
      <element id="Laz_AVL_Tree"/>
      <element id="LazFileUtils"/>
      <element id="LazFileCache"/>
      <element id="LazTracer"/>

      <element name="TFileReference">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReference.fFilename"/>
      <element name="TFileReference.fReferenceCount"/>

      <element name="TFileReference.Filename">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReference.ReferenceCount">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceFlag">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TFileReferenceFlag.frfSearchPathValid">
        <short/>
      </element>
      <element name="TFileReferenceFlag.frfChanged">
        <short/>
      </element>

      <element name="TFileReferenceFlags">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.FOnChanged"/>
      <element name="TFileReferenceList.FTimeStamp"/>
      <element name="TFileReferenceList.FTree">
        <short>Tree of TFileReference instances sorted by file name</short>
      </element>
      <element name="TFileReferenceList.FFlags"/>
      <element name="TFileReferenceList.FSearchPath"/>
      <element name="TFileReferenceList.FUpdateLock"/>

      <element name="TFileReferenceList.UpdateSearchPath">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.IncreaseTimeStamp">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.Invalidate">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.Create">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.Destroy">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.Clear">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.BeginUpdate">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.EndUpdate">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.AddFilename">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TFileReferenceList.AddFilename.Filename">
        <short/>
      </element>

      <element name="TFileReferenceList.RemoveFilename">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TFileReferenceList.RemoveFilename.Filename">
        <short/>
      </element>

      <element name="TFileReferenceList.GetFileReference">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TFileReferenceList.GetFileReference.Result">
        <short/>
      </element>
      <element name="TFileReferenceList.GetFileReference.Filename">
        <short/>
      </element>

      <element name="TFileReferenceList.CreateSearchPathFromAllFiles">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TFileReferenceList.CreateSearchPathFromAllFiles.Result">
        <short/>
      </element>

      <element name="TFileReferenceList.CreateFileList">
        <short/>
        <descr/>
        <seealso/>
      </element>
      <element name="TFileReferenceList.CreateFileList.Result">
        <short/>
      </element>

      <element name="TFileReferenceList.TimeStamp">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.OnChanged">
        <short/>
        <descr/>
        <seealso/>
      </element>

      <element name="TFileReferenceList.UpdateLock">
        <short/>
        <descr/>
        <seealso/>
      </element>

    </module>
    <!-- FileReferenceList -->
  </package>
</fpdoc-descriptions>
filereferencelist.xml (5,217 bytes)   

Juha Manninen

2020-10-18 09:48

developer   ~0126384

Applied, thanks.

jamie philbrook

2020-10-18 14:32

reporter   ~0126387

This install shows duplication from the 3.2.x\win32 compiler and now in the Lazarus files.

at least on my end of it.

so which one is being used ?

I get warnings.

Don Siders

2020-10-18 17:09

reporter   ~0126391

@jamie:

Are you sure this is the correct issue for your comment/question?

jamie philbrook

2020-10-18 17:41

reporter   ~0126395

yes, because it shows as warnings in the message window when building , it wasn't there before.

jamie philbrook

2020-10-18 18:08

reporter   ~0126397

Last edited: 2020-10-18 19:47

View 2 revisions

Ok, I took a closer look, apparently they are not coming from the compiler folder but this is what I have
\compenents\lazutils contains the new file
\compenents\lazutils\lib\x86_64-win32 contain the new .0 and .ppu files
\components\laztils contains a source file of the same name
units\x86_64-win64\win32 both contain the .o and ppu file of that same name dated 9/27/2020
units\x86_64--win64\nogui also contains the same files dated 9/27/2020

you see the confusion here,? I may have missed something but how can you have xml, pas source files and units that are not all matching date wise
with the same name.

Don Siders

2020-10-18 22:24

reporter   ~0126407

Last edited: 2020-10-18 22:27

View 2 revisions

@jamie:

Does ide/filereferencelist.pas stilll exist? That was the original file before it was moved to lazutils... and a possible source of the duplicate message.

I any case, you ay want to file a bug report in LazUtils.., this one relates to the XML file only.

jamie philbrook

2020-10-18 22:59

reporter   ~0126408

I don't know what to say, file a bug report on what? The issue started when this file went in, do you think its just coincidence ? I don't.

Don Siders

2020-10-19 00:23

reporter   ~0126409

@jamie:

> I don't know what to say, file a bug report on what? <

You said you an error in the message window. I assume it had context. File it against that for the "Source Code".

> The issue started when this file went in, do you think its just coincidence ? I don't. <

You are free to make your own assumptions and draw your own conclusions. But:

* The compiler doesn't access the XML documentation files when it compiles. The message has to originate with source code and not an XML documentation file.

* If anything, it is related to 64025 which moved the source file. Sounds like you need to Build and Clean All.

* And finally, I am closing this issue. No one's going to look at it after it is closed.

Issue History

Date Modified Username Field Change
2020-10-18 00:40 Don Siders New Issue
2020-10-18 00:40 Don Siders File Added: filereferencelist.xml
2020-10-18 09:24 Juha Manninen Assigned To => Juha Manninen
2020-10-18 09:24 Juha Manninen Status new => assigned
2020-10-18 09:48 Juha Manninen Status assigned => resolved
2020-10-18 09:48 Juha Manninen Resolution open => fixed
2020-10-18 09:48 Juha Manninen Fixed in Revision => r64044
2020-10-18 09:48 Juha Manninen LazTarget => -
2020-10-18 09:48 Juha Manninen Note Added: 0126384
2020-10-18 14:32 jamie philbrook Note Added: 0126387
2020-10-18 17:09 Don Siders Note Added: 0126391
2020-10-18 17:41 jamie philbrook Note Added: 0126395
2020-10-18 18:08 jamie philbrook Note Added: 0126397
2020-10-18 19:47 jamie philbrook Note Edited: 0126397 View Revisions
2020-10-18 22:24 Don Siders Note Added: 0126407
2020-10-18 22:27 Don Siders Note Edited: 0126407 View Revisions
2020-10-18 22:59 jamie philbrook Note Added: 0126408
2020-10-19 00:23 Don Siders Note Added: 0126409
2020-10-19 00:24 Don Siders Status resolved => closed