View Issue Details

IDProjectCategoryView StatusLast Update
0037956LazarusLCLpublic2020-11-24 16:40
Reportergreenfil Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Platformx86_64OSWindows 
Product Version2.0.10 
Summary0037956: DefaultFormatSettings.DecimalSeparator reset
Descriptionresetting DefaultFormatSettings.DecimalSeparator after changing the Windows user
Steps To Reproduce1) Set DefaultFormatSettings.DecimalSeparator='@' //Any no-default char
2) Windows menu Start-switch user
3) entry user
Additional InformationOnly LCL. There is no error in the terminal application
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

greenfil

2020-10-19 08:52

reporter  

project1.zip (128,253 bytes)

Bart Broersma

2020-10-20 20:22

developer   ~0126429

What exactly is the problem?
Setting DefaultFormatSettings does not affect the OS, so why would you expect this would remain when switching user?
You have a timer code, so I expect that yoy at some point in time see that the decimalseparator changes?
This is because Windos sends a message to the program that it has changed, and this change will be picked up by the LCL application.
You can suppress that by setting Application.UpdateFormatSettings to False.
(Console programs do not respond to this kind of Windows messages)

Bart Broersma

2020-11-22 16:50

developer   ~0127110

No feedback, resolving.

Issue History

Date Modified Username Field Change
2020-10-19 08:52 greenfil New Issue
2020-10-19 08:52 greenfil File Added: project1.zip
2020-10-20 20:22 Bart Broersma Status new => feedback
2020-10-20 20:22 Bart Broersma LazTarget => -
2020-10-20 20:22 Bart Broersma Note Added: 0126429
2020-11-22 16:50 Bart Broersma Assigned To => Bart Broersma
2020-11-22 16:50 Bart Broersma Status feedback => resolved
2020-11-22 16:50 Bart Broersma Resolution open => no change required
2020-11-22 16:50 Bart Broersma Widgetset Win32/Win64 => Win32/Win64
2020-11-22 16:50 Bart Broersma Note Added: 0127110